[sane-devel] Some weirdness with a Canon LiDE 220

Scott Alfter scott at alfter.us
Wed Dec 16 01:23:59 UTC 2015

On 2015-12-15 14:52, John S. Weber wrote:
> On Tue, Dec 15, 2015 at 2:29 PM, Scott Alfter <scott at alfter.us> wrote:
>> I've had this scanner working with prerelease code and the final 
>> 1.0.25
>> release for several months, but when I tried scanning something in the
>> other day, it refused to start up.  I normally use xsane to scan
>> documents; after hitting the "acquire preview" button, the scanner
>> carriage makes a short moving sound, and then a dialog pops up:
>> Failed to start scanner: Invalid argument
> I also have an LiDE220. I noticed a few weeks ago that xsane was giving 
> me
> the same error. I had no problems with other front ends including
> xscanimage, scanimage, and simplescan. About 2 days ago I tried it 
> again
> and xsane worked. I played around a little and it seemed that xsane 
> worked
> if I acquired a preview first, but not otherwise. I don't remember if I
> had acquired a preview from a few weeks ago or not.

Tried again just now, and now nothing works: not xsane, not scanimage, 
not gscan2pdf.  It started running the scanning head down the page in 
xsane when I selected 16-bit bit depth, but it threw an "invalid 
argument" dialog and the scanning head kept going until it hit the stop 
down by the hinge (at which point I unplugged the cable).

It's looking more like the fault is with the backend driver (genesys, in 
this case), not the applications.

Scott Alfter
scott at alfter.us

More information about the sane-devel mailing list