[sane-devel] Some weirdness with a Canon LiDE 220

Scott Alfter scott at alfter.us
Wed Dec 16 04:34:18 UTC 2015

On 2015-12-15 18:28, John S. Weber wrote:
> I just checked the behavior of my LiDE220. I plugged the scanner into 
> USB3,
> started xsane and set it to full color at 300dpi and pushed the scan
> button. Up popped the "invalid argument" dialog. I then acquired a 
> preview
> which worked and thereafter xsane works fine. I could not reproduce the
> error again by closing and restarting xsane or replugging the scanner
> (multiple times). All other front ends I tried worked.

I tried that sequence of steps...it errored out on both attempts to scan 
(scan and preview).

> Your newest symptoms sound like the issues pre 1.0.25. Are you sure of 
> the
> version you're running? Try renaming or deleting your ~/.sane 
> directory.

It's definitely 1.0.25:

salfter at janeway ~ $ emerge -pv sane-backends

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ~] media-gfx/sane-backends-1.0.25::gentoo  USE="ipv6 nls 
usb v4l -avahi -doc -gphoto2 -snmp -systemd -threads -xinetd" 
ABI_X86="32 (64) (-x32)" SANE_BACKENDS="genesys -abaton -agfafocus 
-apple -artec -artec_eplus48u -as6e -avision -bh -canon -canon630u 
-canon_dr -canon_pp -cardscan -coolscan -coolscan2 -coolscan3 -dc210 
-dc240 -dc25 -dell1600n_net -dmc -epjitsu -epson -epson2 -fujitsu 
-gt68xx -hp -hp3500 -hp3900 -hp4200 -hp5400 -hp5590 -hpljm1005 -hpsj5s 
-hs2p -ibm -kodak -kodakaio -kvs1025 -kvs20xx -kvs40xx -leo -lexmark 
-ma1509 -magicolor -matsushita -microtek -microtek2 -mustek -mustek_pp 
-mustek_usb -mustek_usb2 -nec -net -niash -p5 -pie -pixma -plustek 
-plustek_pp -pnm -qcam -ricoh -rts8891 -s9036 -sceptre -sharp -sm3600 
-sm3840 -snapscan -sp15c -st400 -stv680 -tamarack -teco1 -teco2 -teco3 
{-test} -u12 -umax -umax1220u -umax_pp -xerox_mfp" 0 KiB

Total: 1 package (1 reinstall), Size of downloads: 0 KiB

I tried nuking ~/.sane and rerunning the steps above...still no joy.

Next step might be to bring the scanner in to work and try it out with 
my old computer that I took into the office.  There, it'd be running on 
Gentoo Linux in a VirtualBox VM under Windows 7. I already have that box 
working with an ancient LiDE 20 that Canon doesn't support under 
anything newer than Windows XP and would just need to compile in the 
genesys backend (the LiDE 20 uses the plustek backend).

Scott Alfter
scott at alfter.us

More information about the sane-devel mailing list