[sane-devel] Some weirdness with a Canon LiDE 220

Scott Alfter scott at alfter.us
Thu Dec 17 18:09:24 UTC 2015

On 12/16/2015 9:20 PM, Stef wrote:
> On 17/12/2015 04:41, Scott Alfter wrote:
>> I then put the patch back in (or, more precisely, didn't patch it
>> out), recompiled, and tried again under the newer kernel.  It seems to
>> be running about the same with the workaround as without: an "invalid
>> argument" error at 4800 dpi, but it works at 2400 dpi and below.
>     before scanning, the scanner calibrates itself. The higher the
> resolution, the longer the calibration takes. The calibration data is
> then cached , and subsequent scans are faster. That explains the delay
> you saw at 2400 dpi.
>     For the 4800 dpi scan, what is the scan area used (width, height) ?

The first time, I think I tried a full-page scan (8.5x11").  I then cut
it back to 1x1" and still got an error.

This morning, I tried again with a smaller scan area.  It still errored
out at 0.1x0.1", but it worked at 0.05x0.05".  I then tried going back
to 0.1x0.1", but got an error again.

Scott Alfter
scott at alfter.us

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 648 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20151217/74c59958/attachment.sig>

More information about the sane-devel mailing list