[sane-devel] (Solved) Need help with Epson scanner problems-Fedora 20

Terry Duell tduell at iinet.net.au
Fri Jan 2 04:50:20 UTC 2015

On Fri, 02 Jan 2015 10:35:06 +1100, Terry Duell <tduell at iinet.net.au>  

> On Fri, 02 Jan 2015 08:19:07 +1100, Terry Duell <tduell at iinet.net.au>  
> wrote:
>> [snip]
>>>> Now, finally, to the specifics of the problem.
>>>> I can start Gimp and select File -> Create:XSane dialog and the XSane
>>>> windows appear OK. I can select "Preview" and get a preview scan OK,  
>>>> but
>>>> when "Scan" is selected I get an error "Failed to start scanner: Error
>>>> during device IO".
>> [snip]
>>> Is the scanner connected to a USB3 (often blue) port? If so, move it to
>>> a USB 2 port. There are some issues with USB3 ports that got fixed
>>> recently in GIT but are not in the Fedora version (nor most likely any
>>> other Linux distro's version)
>> I have tried both USB2 and USB3, and get the same behaviour.
>> I might have a look at the latest GIT. I assume it would be the  
>> sane-backends that I should build?
>> The Fedora packaging ends up as 3 rpms (  
>> sane-backends-drivers-scanners, sane-backends-libs, sane-backends)  
>> which are probably all built from sane-backends. I'll check the Fedora  
>> src.rpms to see how they do it.
>> I'll come back when I know more, and hopefully others may have seen  
>> this specific behaviour and can point to a solution.
>> Thanks for your help.
> Sorry, I should have replied to the list. That usually happens  
> automagically.
I can now report that the problem appears to be solved.
I got a copy of the GIT repo, and the Fedora  
sane-backends-1.0.24-7.fc20.src.rpm, and built new sane-backends-libs,  
sane-backends, sane-backends-drivers-scanners using rpmbuild, but without  
any of the patches included in the Fedora  
It built OK, and installed OK.
The scanner is now working as I remember it did (just like a bought one!),  
and using a USB2 port.
So, not exactly sure what it fixed, but given that it "always" worked then  
didn't, I assume it was due to some change in Fedora 20 that changes in  
the current GIT source have fixed.
It is curious that others haven't had this problem...maybe I'm the only  
one using Fedora 20 and an Epson 3490 with snapscan.

Terry Duell

More information about the sane-devel mailing list