[sane-devel] sane-devel Digest, Vol 120, Issue 20

"Cedric Bhihe (毕生泰)" cedric.bhihe at gmail.com
Sat Jun 20 18:58:35 UTC 2015

A good day to everybody.
I keep reading about flatbed scanners from Canon (in particular of the LIDE
series) not working when USB-plugged in under Linux but working fine under
Windows. I have exactly the same problem with a LIDE 25 and an HP 4400c

Yes, both scanners are old but they are in excellent condition, (very low
mileage + many years forgotten somewhere in their original packing).  Both
work flawlessly under legacy Windows XP as well as under Win 7 on different
machines, including one that runs a dual Lx/Win boot.

As far as 'sane' front-ends go, I downloaded and installed two from the 
Software Center and tried them repeatedly.
- simple scan 3.12.1
- xsane 0.998 whose author I even contacted, Oliver Rauch, hoping for 
Unfortunately I got no answer.

Nothing seems to work under Linux with a 'sane' based gui for those two 
-1- it was not always the case. Up until about 8-10 weeks ago, xsane 
used to work
flawlessly for me. Nothing in my system (hard and soft) changed since then,
apart from regular stable and security related updates as provided by 
-2- I can scan w/o an itch from my Ubuntu terminal using 'scanimage'. I 
do that
on a daily basis with no errors.

I already wrote about that here, about 40 days ago, and got a resounding 
  for an answer. No idea why.

Anyway I believe this is completely unrelated to the USB3 issue that is 
now widely
publicized. This probably has to do with some change in the kernel AND 
the way
the two afore mentionned 'sane' based gui packages handle communication 
the scanner or the daemon that handles USB comm. or some' else.
Something happened about 8 to 10 weeks go and I don't know what it is.

Since I am no techie, I am stuck, but at least 'scanimage' on terminal 
The downside with scanimage is despite all available options
- no preview is available (pre-processing),
- no collating batch (multi-page) scans (post-processing) is possible,
- there is no saving scans directly as pdf (post-processing).


Ubuntu 14.04.2 v3.16.0-41-generic x86_64
on Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz
Motherboard 30C5 Version KBC v.71.36 by HP
BIOS HP version: 68MVD Ver. F.15 (2008.02.12)


On 20/06/15 14:00, sane-devel-request at lists.alioth.debian.org wrote:
> Send sane-devel mailing list submissions to
> 	sane-devel at lists.alioth.debian.org
> To subscribe or unsubscribe via the World Wide Web, visit
> 	http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
> or, via email, send a message with subject or body 'help' to
> 	sane-devel-request at lists.alioth.debian.org
> You can reach the person managing the list at
> 	sane-devel-owner at lists.alioth.debian.org
> When replying, please edit your Subject line so it is more specific
> than "Re: Contents of sane-devel digest..."
> Today's Topics:
>     1. Re: Canon LIDE 110 + USB3 (Marc Cousin)
> ----------------------------------------------------------------------
> Message: 1
> Date: Fri, 19 Jun 2015 15:57:03 +0200
> From: Marc Cousin <cousinmarc at gmail.com>
> To: Heinz Wiesinger <HMWiesinger at liwjatan.at>
> Cc: sane-devel at lists.alioth.debian.org
> Subject: Re: [sane-devel] Canon LIDE 110 + USB3
> Message-ID: <478249274.zdL7Kf9XdV at marco>
> Content-Type: text/plain; charset="utf-8"
> On Thursday 30 April 2015 13:15:17 Marc Cousin wrote:
>> On 18/04/2015 18:46, Marc Cousin wrote:
>>> On 18/04/2015 18:27, Marc Cousin wrote:
>>>> On 18/04/2015 12:35, Heinz Wiesinger wrote:
>>>>> On Saturday 18 April 2015 10:58:31 Marc Cousin wrote:
>>>>>> Hi,
>>>>>> I've got a brand new computer with USB3 all over the place, and cannot
>>>>>> use my "old" LIDE 110 with it, even with a git version. The scanner is
>>>>>> still working, as it works when connecter to my older laptop, through
>>>>>> USB2. It doesn't work with a git checkout from a few minutes ago.
>>>>>> I see that some drivers have received some patches to work around
>>>>>> problems with USB 3. Is there something to be done to the genesys
>>>>>> driver
>>>>>> too ? What can I provide to help solving this ?
>>>>> Hi,
>>>>> I have the same problem with the LIDE 210. In a message from last
>>>>> month, Stef
>>>>> asked for usbpcap log from windows (see
>>>>> http://lists.alioth.debian.org/pipermail/sane-devel/2015-March/033202.ht
>>>>> ml
>>>>>    for details). Unfortunately I don't have access to a Windows
>>>>> computer having
>>>>> USB3 ports. So if you have and you could provide those logs, it might
>>>>> help in
>>>>> figuring out what's going wrong.
>>>>> Grs,
>>>>> Heinz
>>>> I have no windows installed. I have one in a KVM box, should I give it a
>>>> try ?
>>> I gave it a try, in the KVM windows, scanning works. It is seen as USB2
>>> from windows though, I don't know if this is of any importance.
>> So,
>> Is this dump (from a virtulized windows seeing USB2) interesting ?
>> Regards
> Hi,
> I'm back on this, after a while away from home. Is there anything I can
> provide ?
> To sum up:
> - The LIDE110 doesn't work from SANE (git checkout from 10 minutes ago) +
> Linux (4.0.5): I only have problem with the scanner. Any other periphal I
> plugged in worked ok (mouse, usb card reader, usb disk drive, keyboard)?
> - It works in Win7, virtualized in KVM, using the exact same USB3 port (seen
> as USB2 from Windows)
> - It almost works when all debug traces are activated in SANE (it fails much
> later)
> I am willing to capture anything you want, just tell me (and give me pointers
> to how to do the requested captures). I could even (but as a last resort, as I
> don't have space for it right now) install a Win7 on this machine.
> Regards
> ------------------------------
> Subject: Digest Footer
> _______________________________________________
> sane-devel mailing list
> sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
> ------------------------------
> End of sane-devel Digest, Vol 120, Issue 20
> *******************************************

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20150620/8c199f5f/attachment.html>

More information about the sane-devel mailing list