[sane-devel] "Error during device I/O" with Fujitsu fi65-F (epjitsu backend)

Jonas Neubert jonas.neubert at gmail.com
Thu Mar 19 06:06:50 UTC 2015

I'm using USB2, and the git repo checkout was Monday late evening, less than an hour before I sent my last email. I already destroyed the test environment I used on Monday which is why I can't tell you the exact time or commit hash that was checked out. I can try again tomorrow morning if there have been relevant changes in the repo since Monday night.


---- On Wed, 18 Mar 2015 17:39:13 -0700 m. allan noah<kitno455 at gmail.com> wrote ---- 
 > That kind of error implies that we are having a usb problem, where 
 > perhaps a command is being lost, or the data toggle is not being 
 > reset. How old is your git repo checkout? Are you using USB 3 ports? 
 > allan 
 > On Tue, Mar 17, 2015 at 1:34 AM, Jonas Neubert <jonas.neubert at gmail.com> wrote: 
 > > I just did a few successful scans! The patch does indeed make the scanner work, with two caveats: 
 > > 
 > > 1) Only every other call to scanimage results in a successful scan, the 2nd, 4th, 6th, etc scan fails the same way as before. 
 > > 2) Even during successful scans the debug output contains an 'Error during device I/O', although I'm not sure if this is even a problem. 
 > > 
 > > Debug output from a successful scan (1st, 3rd, 5th, ... call to scanimage): https://gist.github.com/jonemo/489414e8bc5590998890 
 > > Debug output from an unsuccessful scan (2nd, 4th, 6th, ... call to scanimage): https://gist.github.com/jonemo/8a4cf7d13a50556b3c41 
 > > 
 > > I also tried scanning at 600dpi and it worked successfully (every other time). 
 > > 
 > > -Jonas 
 > > 

More information about the sane-devel mailing list