[sane-devel] Xsane can't find scanner - again, but this one is USB

Johannes Meixner jsmeix at suse.de
Thu Nov 5 11:06:52 UTC 2015


an addendum FYI:

On Nov 3 07:29 m. allan noah wrote (excerpt):
> When I run xsane with no scanners connected,
> I get a dialog which says so- it does not just quit.

I like to confirm that xsane behaviour also on my system
and even more when I run xsane when "scanimage -L" shows
"No scanners were identified", then xsane first shows
this notification popup:
   No devices
   no devices available
   [Close]       [Help]
and after clicking [Help]
xsane shows a subsequent notification popup:
   No devices available
   Possible reasons:
   1) There really is no device that is supported by SANE
   2) Supported devices are busy
   3) The permissions for the device file do not allow you
      to use it - try as root
   4) The backend is not loaded by SANE (man sane-dll)
   5) The backend is not configured correctly
      (man sane-"backendname")
   6) Possibly there is more than one SANE version installed
clicking [Close] finishes xsane.

Kind Regards
Johannes Meixner
SUSE LINUX GmbH - GF: Felix Imendoerffer, Jane Smithard,
Graham Norton - HRB 21284 (AG Nuernberg)

More information about the sane-devel mailing list