[sane-devel] multiple, identical scanners?

Jeremy Chacon chaco001 at umn.edu
Wed Nov 11 21:49:30 UTC 2015

Hi Johannes,

Thanks for your very thorough response!

It turned out you were correct, it was a USB issue. The scanners that
always worked were connected to USB 2.0 ports, while the scanners that gave
trouble were always connected to USB 3.0 ports (xhci_hcd when I did lsusb).

Putting all the scanners on the older port type solved the problem.

Thanks very much!



On Wed, Nov 11, 2015 at 2:31 AM, Johannes Meixner <jsmeix at suse.de> wrote:

> Hello,
> On Nov 10 14:09 Jeremy Chacon wrote (excerpt):
>> ... sometimes gives an I/O Error ...
> In general "sometimes I/O Error" indicates that the root
> cause is somehow hardware related where "hardware" means
> the actual computer hardware plus the computer's built-in
> firmware (i.e. BIOS or UEFI) and "hardware related" means
> computer hardware plus firmware plus Linux kernel driver
> plus low-level hardware related software (e.g. libusb).
> You may have a look at "a stack consisting of various
> layers must be functional in its entirety" in
> https://en.opensuse.org/SDB:Configuring_Scanners#Basics
> You did not tell how your scanners are connected to your
> computer.
> If your scanners are connected via USB:
> There are currently issues with USB ports where the kernel
> module "xhci" is used as kernel driver.
> When "lsusb -t" shows "Driver=xhci_hcd" for the USB bus
> and port where the USB scanner is connected (see "lsusb" where
> the scanner is connected), then there could be issues depending
> on the computer hardware and firmware.
> In this case see
> https://bugzilla.opensuse.org/show_bug.cgi?id=856794
> in particular see
> https://bugzilla.opensuse.org/show_bug.cgi?id=856794#c24
> that reads (excerpt):
> -----------------------------------------------------------------
> My machine has 4 USB ports, two labeled with
> the "super speed" USB logo (a.k.a. USB 3) and
> two labeled with the normal USB logo (a.k.a. USB 2)
> but for all 4 ports xhci is used and it fails on all 4 ports.
> -----------------------------------------------------------------
> and see
> https://bugzilla.opensuse.org/show_bug.cgi?id=856794#c40
> When your scanner is not connected at a USB port where the
> kernel module xhci_hcd is used as kernel driver (e.g. when
> your scanner is connected at a USB port where the kernel
> module uhci_hcd or ehci_hcd is used as kernel driver),
> then have a look at "Trouble-Shooting (Debugging)" in
> https://en.opensuse.org/SDB:Configuring_Scanners
> For example in your case to get USB debugging information
> you could use comands (as root) like
> -----------------------------------------------------------------
> scanimage -L
> -----------------------------------------------------------------
> Kind Regards
> Johannes Meixner
> --
> SUSE LINUX GmbH - GF: Felix Imendoerffer, Jane Smithard,
> Graham Norton - HRB 21284 (AG Nuernberg)
> --
> sane-devel mailing list: sane-devel at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/sane-devel
> Unsubscribe: Send mail with subject "unsubscribe your_password"
>             to sane-devel-request at lists.alioth.debian.org


M. Chacon, Ph.D.*

*Post-Doctoral Associate, Harcombe Lab*
*University of Minnesota*
*Ecology, Evolution and Behavior*
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20151111/8c5ac23a/attachment.html>

More information about the sane-devel mailing list