[sane-devel] Xsane can't find scanner - again, but this one is USB

Olaf Meeuwissen paddy-hack at member.fsf.org
Sat Oct 31 03:17:57 UTC 2015

MR ZenWiz writes:

> Last time I had this problem, it was on my laptop at my friend's house
> with a wireless HP Envy printer.  Eventually that worked when I added
> the printer through CUPS.
> At home, I run Xubuntu 14.04.3 with an HP 5740 all-in-one attached on
> the USB (bus 3, device 14).

Others have already commented on the fact the USB3 support and the xhci
kernel driver may be causing your trouble.

> When I first installed this it was fine, everything worked.
> Tonight I tried to scan a document, and xsane can't find the
> scanner/printer/etc.
> I removed it with CUPS and reinstalled - no change.
> I removed it and used the Xubuntu printer manager to install it, and
> even printed a test page, and that works, and it now shows up in CUPS,
> but xsane still can't find the scanner.
> Why does xsane have so much trouble locating what's there and operational?
> How does it manage to forget what used to be there (and still is)?

I have had XSane refuse to start on me when I switched devices in the
past.  XSane keeps a cache with information on devices and settings in
the ~/.sane/xsane/ directory.  Removing that directory may help.

However, when troubleshooting device detection issues, it is better to
use the scanimage command-line utility first.  See the manual page for
usage details but

  scanimage -L

will give the list of detected, usable devices.  You can select between
these with the -d option.

> [snip]

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
Support Free Software               Support the Free Software Foundation
https://my.fsf.org/donate                        https://my.fsf.org/join
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9

More information about the sane-devel mailing list