[sane-devel] Scanner Lide 210 working with old and bleeding edge distro, but not with current stable distro

Sebastian Weber s.wbr at gmx.de
Sun Feb 21 00:43:56 UTC 2016


I have a Canon LIDE 210, which is well supported by SANE and the genesys

So far, I have been using the scanner connected to my PC, which did run
openSuse 13.2  (And SANE 1.0.24 or .25)
Now I upgraded to openSuse Leap 42.1 ("stable release"), and the scanner
does not work. (SANE 1.0.24 and .25)
However, my laptop runs openSuse Tumbleweed ("bleeding edge release"),
and the scanner works fine. (SANE 1.0.25)

In all cases, SANE was installed from the official openSuse repositories.

About the problems with openSuse Leap 42.1:
With 1.0.24, the scanner hesitates about 10 seconds, and then starts to
stutter. The head moves just a centimeter or so, and does not home. The
picture consists of many vertical, noisy stripes, so the computer seems
to receive at least something analog...
With 1.0.25, the scanner behaves the same way, but the software aborts
with an I/O error.

(Of course, I tried other USB ports, but the scanner was definitely
working at them before!)

I'm a bit clueless. The scanner is in general supported by these SANE
versions, but does not work with my particular distribution. However,
SANE uses libusb, which means it talks more or less directly to the
scanner - this should work straight forward. So I have no idea what the
problem could be.

Does anybody have an idea?


Another issue: I also tried to compile the latest stable version of SANE
from the official SANE websites.
I have libusb 1.0.0 and 0.1.4 installed (plus development packages for
headers etc.).
I configured the build with/without --enable-libusb_1_0. In both cases,
scanimage claims that it was built without USB support, and does not
find my scanner (sane-find-scanner does). I saw this when I enabled
debug outputs by setting SANE_DEBUG_...=255.

Any Idea what I've done wrong?


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20160221/4e0854b1/attachment.html>

More information about the sane-devel mailing list