[sane-devel] Sane stopped working with my HP Scanjet 8200

James Klaas jklaas at appalachian.dyndns.org
Thu Jun 16 14:05:10 UTC 2016

I was interested in trying gscan2pdf, so I installed it on one of my
computers at home to access my networked Scanjet 8200 sitting on my main
server. I was interested in trying to use the ADF. I've had hit or miss
(mostly miss) success with the ADF, but it's been long enough since I tried
it that I thought there would be some improvement.

Of course, I forgot that I left a document on the bed, but it shouldn't
have interfered with the ADF. In any case, the ADF "jammed" and saned
became wedged on the server. That's usually bad news since it sometimes
requires me to restart the whole server since often the USB stuff seems to
get wedged as well and merely unplugging and replugging the scanner in
doesn't always help.

Well, after fussing with it for a while, including uninstalling sane,
reinstalling sane (and sane-utils) learning how to get systemd working with
sane (since it's Debian 8), then going through and making sure the udev
pieces were in place, I seem to have lost all functionality.

Further troubleshooting. Running saned as root after turning off the
systemd running of it "systemctl stop saned.socket" followed by "systemctl
disable saned.socket", then running saned in debug mode.

# saned -d
[saned] main: starting debug mode (level 2)
[saned] saned (AF-indep+IPv6) from sane-backends 1.0.24 starting up
[saned] do_bindings: [0] bind failed: Address already in use
[saned] check_host: access by remote host: ::ffff:
[saned] init: access granted to jklaas@::ffff:
[saned] process_request: bad status 22
[saned] bailing out, waiting for children...
[saned] bail_out: all children exited

Using gscan2pdf on a remote machine gives me the above.

sane-find-scanner sees the scanner when run either as root or as a user. If
I run "scanimage -L" while running saned in debug mode, it segfaults. If I
run "scanimage -L" when saned is run from systemd it doesn't segfault.
Looking at syslog it seems to start saned three times though.

I feel like I'm flailing here, so any direction would be helpful in further
troubleshooting this.

I also feel like I fight this battle almost every time I try to scan
something. It's pretty frustrating.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20160616/0e9fe0bc/attachment.html>

More information about the sane-devel mailing list