[sane-devel] Problem getting Epson V370 Photo working under OpenSuSE

Olaf Meeuwissen olaf.meeuwissen at avasys.jp
Wed Mar 9 23:10:14 UTC 2016


Graham Freeman writes:

> I am having trouble with my new Epson V370. I have not been able to
> successfully apply the advice that has been recently reported working
> under a different version of Linux.
> I installed iscan-2.30 and iscan-data-1.36 from the
> iscan-perfection-v370-bundle-1.0.0.x64.rpm.tar.gz from Epson.

You need to install iscan-plugin-perfections-v370 too.  See the
README.rst file that came with the bundle.
# It's included for a reason ;-)

> I used YaST/scanner to configure the scanner.

There should be no need to configure the scanner with YaST.
# In my experience, YaST just gets in my way.

> It presents two items in its list:  
> epkowa Epson (unknown model) at epkowa:usb:003:004  
> Not Configured: EPSON Perfection V37/V370 USB scanner (vendor=0x04b8 [EPSON], product=0x014a [EPSON Perfecttion V37/V370]) at libusb:003:004  
> If I attempt to edit the second to configure it, I get a popup message
> "Possibly Problematic Driver The epkowa driver may cause problems on
> 64-bit x86_64 architecture". Continuing, it does not configure that
> entry.

Ask (open)SUSE.
I am not aware of problems on x86_64 in the last few years.

> If I attempt to edit the first to configure it, I get the same popup
> message.
> When I run xsane from the command line, I get a popup "scanning for
> devices" which stays up for around 30sec. No windows come up, but
> xsane does not complete either. It is still running but without a
> graphical interface. If I turn the scanner off, xsane then completes
> and I get the new command prompt.
> I have tried the "Image scan! for linux" that is now installed from
> iscan. It does not give a graphical interface. Right-clicking on that
> gives me a popup "Could not send command to scanner. Check the
> scanner's status".
> The command "sane-find-scanner" gives:  
> found USB scanner (vendor=0x04b8 [EPSON], product=0x014a [EPSON Perfection V37/V370]) at libusb:003:005  
> The command "scanimage -L" delays for about 30 seconds before
> reporting "device `epkowa:usb:003:005' is a Epson (unknown model)
> flatbed scanner"
> The command "iscan" sits silently for about 60 sec before completing
> and I get a new command prompt. The scanner does nothing during this
> time.
> The command "scanimage -d epkowa -v >/tmp/file.jpg" behaves the same
> way. So also does the command "scanimage -d epkowa:usb:003:005 -v
> >/tmp/file.jpg"
> Nothing that I do from Linux will elicit a response from the scanner.  

If still you cannot get scanimage to work *after installing the plugin
package*, then provide the output of

  SANE_DEBUG_EPKOWA=HEX scanimage >/dev/null

to the list.

> I have successfully got the scanner to work under MS-Windows, so the
> hardware is fine. I could not find a file "esfwdd.bin" that Winfried
> referred to in her email, either in the files that Epson supplies for
> Linux, nor in the files that were installed when I tried under MS.

Hope this helps,
Olaf Meeuwissen, LPIC-2       FLOSS Engineer -- EPSON AVASYS CORPORATION
       Free Software Foundation Associate Member since 2004-01-27
    Support Free Software                  https://my.fsf.org/donate
    Join the Free Software Foundation        https://my.fsf.org/join

More information about the sane-devel mailing list