[sane-devel] ADF on Epson ET-4500 using epson2 backend not working

Olaf Meeuwissen paddy-hack at member.fsf.org
Fri Sep 16 09:23:41 UTC 2016


Roger Sewell writes:

> Hi - I'm new here.
> I've been trying to get xsane to work on an Epson ET-4500
> print/scan/copier. Everything works except scanning from the automatic
> document feeder (ADF) - I can scan fine from the flatbed.

The ET-4500 is not documented as supported by the epson2 backend.  There
is a third party backend, part of Utsushi[1], that claims to support it.
Over USB, at least.

 [1] https://github.com/utsushi/utsushi

> Whether I try with xsane or with scanimage I get the same outcome:
>    ADF starts working. About half a page into the first page the ADF
>    stops, and the front end gives an error message:
>       sane_start: Error during device I/O
>    while at the scanner end the scanner hangs up and demands it be
>    power-cycled.
>    In addition the eject command doesn't work (ever).
> Any help would be appreciated.

A compressed debug log, preferably over USB, would be helpful.

  SANE_DEBUG_EPSON2=128 scanimage [options] 2> debug.log
  xz debug.log

should do the trick.

> The rest of this email is information about my installation.
> [...]
> I have also tried using the usb connection, with exactly the same result
> in all respects.
> I also tried using scanimage by
>    scanimage -p --mode=color --batch='temp%d.pnm' --source=Automatic
> and by
>    scanimage -p --mode=color --batch='temp%d.pnm' --source=Automatic --buffer-size=3000
> and exactly the same problem occurs again.
> Any ideas would be most welcome.

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list