[sane-devel] Visioneer RoadWarrior Scanner Black Output

Andrew Charnley ac at igaro.com
Wed Aug 23 20:00:26 UTC 2017

Hi All,

I just picked up one of these portable scanners, it works well in

In Linux and either xsane or simple-scan however it always scans a
completely black page.

Thinking it was a calibration issue I ran:-

SANE_DEBUG_GENESYS=255 scanimage -d genesys --calibrate 2>calibrate.log

Which at first reported it couldn't find the black bars on the sheet. I
made one using: http://www.fixya.com/support/t17003105-calibration_shee
t_visioneer_roadwarrior and the error resolved.

The calibration value "01 e8 00 00 00" is written. There is still an
error in the log but it appears to be OK given it writes the file. 

scanimage: setting of option --calibrate failed (Operation not

I'm unsure if it's calibration anyhow as it worked OK-ish in Windows
(washed out, but had an image).

Scans are still completely black, unsure what to try next?

calibrate.log file can be found: https://bugs.launchpad.net/ubuntu/+sou

More information about the sane-devel mailing list