[sane-devel] Canon LiDE 220

Torsten Mohr tmohr at s.netic.de
Tue Jan 10 18:09:07 UTC 2017


it is not yet working, here is what I did so far:

In /etc/udev/rules.d/55-libsane.rules:
# Canon LiDE 220 USB Scanner
ATTR{idVendor}=="04a9", ATTR{idProduct}=="190f", ENV{libsane_matched}="yes", 

In /tmp/canon_script.sh:
#! /bin/bash

date > /tmp/canon.txt
env >> /tmp/canon.txt

When plugging the scanner in then /tmp/canon.txt is created with the expected 
content, so udev seems to work as expected.

I downloaded sane-backends-1.0.25
mv /usr/lib/sane /usr/lib/sane.old
mv /usr/lib64/sane /usr/lib64/sane.old
In sane-backends-1.0.25:
configure --prefix=/usr, make, make install

Still scanimage -L does not find anything.

Then I tried strace -e open scanimage -L 2>log.txt

In log.txt i see that /usr/etc/sane.d/genesys.conf is opened and in there are 
some mappings of VID/PID.
I added:
usb 0x04a9 0x190f

Still no success.

Does anybody have a hint?

Best regards

Am Montag, 9. Januar 2017, 11:53:03 CET schrieb Johannes Meixner:
> Hello,
> On Jan 8 16:44 Torsten Mohr wrote (excerpt):
> > I bought the Canon LiDE 220, it is documented that it is
> > fully supported by the genesys backend:
> > 
> > http://www.sane-project.org/sane-mfgs.html#Z-CANON
> It is documented to be supported by
> the current SANE release 1.0.25.
> > sane-backends-1.0.24-4.40.x86_64
> > sane-backends-32bit-1.0.24-4.40.x86_64
> > sane-backends-autoconfig-1.0.24-4.40.x86_64
> Accordingly I would first and foremost upgrade
> to the current SANE release 1.0.25.
> See
> https://en.opensuse.org/SDB:Configuring_Scanners
> Kind Regards
> Johannes Meixner

More information about the sane-devel mailing list