[sane-devel] XSANE

Ron Anstis ron.anstis at skymesh.com.au
Wed Jan 18 05:09:39 UTC 2017

Dear Alioth,
                     I have been trying for six hours to get XSANE to 
work with my Canon MP 970 printer. The programme installed and runs 
normally, it recognises the printer, but when I ask for a preview, 
nothing happens. The software does not freeze - the preview can be 
cancelled, and all the rest of the programme still works - but no 
scanned image appears, despite a five minute wait before cancellation.
     Simple scan and scan2pdf both work, but neither are as 
sophisticated as XSANE, nor have the features I want.
     I have visited 
"file:///usr/share/sane/xsane/doc/sane-problems-doc.html", and, although 
my specific problem is not mentioned, I have run through most of the 
remotely applicable suggestions without success. The back end is there, 
SANE is there, the scanner shows up correctly in Terminal and I have 
commented out all back ends except those for Canon and Pixma in 
sane.d/dll.conf. I tried "$find / -name "*sane*" | less" as root, but 
nothing appeared except a blinking cursor, despite me waiting ten 
minutes or so.
     Desktop PC AMD quad-core 3.6 GHz processor, 16 GB RAM 2 GB GE-Force 
graphics, multiboot system with Linux Mint Sarah, Win 7 and Win XP
     Does anyone have any ideas??

     Ron Anstis.

Postscript - After writing this, I tried   gdb xscanimage
     					   r <enter>
     					   after the frontend returned:
     					   backtrace <enter>

for the third time, with the the following result:
(gdb) r
Starting program: /usr/bin/xscanimage
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffedbd0700 (LWP 12241)]
[New Thread 0x7fffec331700 (LWP 12242)]
[New Thread 0x7fffe0ff0700 (LWP 12244)]
[Thread 0x7fffe0ff0700 (LWP 12244) exited]
[New Thread 0x7fffe0ff0700 (LWP 12246)]
[New Thread 0x7fffdbfff700 (LWP 12247)]
[Thread 0x7fffec331700 (LWP 12242) exited]
[Thread 0x7ffff7fb8980 (LWP 12237) exited]
[Thread 0x7fffdbfff700 (LWP 12247) exited]
[Thread 0x7fffe0ff0700 (LWP 12246) exited]
[Inferior 1 (process 12237) exited normally]
(gdb) backtrace
No stack.

Before I ran the command "backtrace", there was a limited GUI front end 
returned,  and I successfully obtained a preview, and was able to do a 
scan, and save it. Weird??

More information about the sane-devel mailing list