[sane-devel] Pushing autofoo changes to Alioth leaves me "stumped"

Olaf Meeuwissen paddy-hack at member.fsf.org
Wed Jun 7 13:19:51 UTC 2017

Hi list,

I just pushed a commit changing configure.ac and backends/Makefile.am.
Here's part of what that gave me.

 remote: *** A Makefile was modified; please ./configure && make on Alioth
 remote: *** Contact sane-devel if you don't know what to do

I'm clueless, hence my mail.

That is, I know that I should rerun automake and autoconf (and in that
order) or just run autoreconf and let that take care of things.  Hey,
I've been doing autofoo for 15 years.  But the above message leaves me
stumped.  Totally, completely and utterly.

I've logged in to alioth.  I have no idea what "current" directory I
should be running this in.  Moreover, it very much looks like whatever
tools are needed for what should be done are not available on Alioth.

The closest thing to a git repository clone I could find lives in


It has the commit I just pushed.  Maybe this is that current directory
then?  Let's try


Barfs towards the end with

  configure: creating ./config.status
  chmod: changing permissions of `./config.status': Operation not permitted
  configure: error: write failure creating ./config.status

Tried running make anyway.

  Generating epsonds.conf from epsonds.conf.in
  /bin/bash: epsonds.conf: Permission denied
  make[1]: *** [epsonds.conf] Error 1
  make[1]: Leaving directory `/var/lib/gforge/chroot/home/groups/sane/sane-backends-lists-git/backend'
  make: *** [all-recursive] Error 1

So apart from the lack of tools to do what *should* be done, there are
also a bunch of permission issues that make the message when pushing,
eh, well, rather useless.

The message when pushing is courtesy of the git post-receive hook.  If I
rip that out, what will change for the worse, stop working or just plain

In the mean time, I've just run autoreconf on my debian-8-full Docker
container[1] and pushed the "fall out".

 [1] https://gitlab.com/sane-project/ci-envs

Hmm, that triggered a pile of such messages and tried to

  remote: cd .. && make  am--refresh
  remote: make[1]: Entering directory `/var/lib/gforge/chroot/home/groups/sane/sane-backends-lists-git'
  remote: /bin/bash ./config.status --recheck

failing with the same permission errors as before.  All this is rather
disappointing to see and I'd like to do something about it.  Clues and
suggestions very welcome.

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list