[sane-devel] Fix PPA build

James Duvall jamestemp8873-sane at yahoo.com
Tue May 9 20:06:02 UTC 2017

OK, now it makes more sense to me.  I saw that the last released version was 1.0.25, but I didn't fully comprehend that your ppa is a pre-release for 1.0.26.  When 1.0.26 is released, of course you would want these builds to compare earlier than the released version.
One thing I still don't fully comprehend.  libsane=1.0.26~preXXX depends on libsane-common=1.0.26~preXXX, but libsane=1.0.26~preXXX also breaks libsane-common<<1.0.26
This seems like a conflict.  Isn't this saying that libsane breaks the same version that it depends on?
Sorry if I am being frustrating or dense on this topic.  As I understand, apt and dpkg won't allow 2 different versions of the same package to be simultaneously installed.  If the pre-release libsane requires a specific version of libsane-common, doesn't that automatically imply that it breaks/conflicts with any other version?  libsane=1.0.26~preXXX will also break 1.0.27 or 1.1 or anything else that is released in the future, right?
 Using your instructions, I still can't install using apt, dpkg.  I installed synaptic, but I get the same error and refusal to install ().  I am running yakkety, so maybe there is some difference from trusty.

However, this is not a big problem for me.  I am able to automatically build from the sane-backends package on your ppa, so I can test my MG5420 with the latest fixes.  I'll send another email once I have verified all functions and the scanbd script you sent me.
Many thanks,James
    On Tuesday, May 9, 2017 11:36 AM, Rolf Bensch <rolf at bensch-online.de> wrote:

 Hi James,

Am 08.05.2017 um 22:22 schrieb James Duvall:
> Rolf,
> Thanks for getting your ppa back up and running.  However, I am not able
> to install the libsane package using apt, even when I try to force the
> version.  I believe that your new version numbering with ~ is causing
> the problem.
> ver=1.0.26~ppa20170508-yakkety0; sudo apt-get install libsane=$ver
> libsane-common=$versane-utils=$ver

I used synaptic for Trusty and it's working.

You can use an alternative more complex procedure to get the updates
from my ppa:

(1) search for installed SANE packages:
$ dpkg -l *sane*

(2) purge all SANE packages with the version '1.0.26[-+]ppa{date}
*without* removing dependent packages:
$ sudo dpkg --force-all -P libsane libsane-common sane-utils [other
installed packages]

(3) reinstall SANE:
$ apt-get -f install

(4) reinstall all other removed packages, e.g.:
$ sudo apt-get install libsane-dev

> Apt complains that
> The following packages have unmet dependencies:
>  libsane : Breaks: libsane-common (< 1.0.26)
>            Breaks: libsane-common:i386 (< 1.0.26)
> E: Unable to correct problems, you have held broken packages.
> I think the issue is that version 1.0.26~ppa20170508-yakkety0 compares
> less than 1.0.26 due to special rules for handling ~ in version
> numbers.  The following shows this:
> dpkg --compare-versions 1.0.26~ppa20170508-yakkety0 lt 1.0.26 && echo true
> true

This is correct. SANE 1.0.26 isn't released yet.
Inspired from your comment I renamed the version in my ppa to
'1.0.26~pre{date}'. This makes it more transparent that this is a

> I created a local repository and re-packaged as version
> 1.0.26+ppa20170508-yakkety0 and was able to install with no problems, so
> maybe change the ~ for + or some other separator?  I am not experienced
> with debian package management, so please disregard if I am missing
> something.

Then you'll get the next update after we started the development of SANE
version 1.0.27, then AKA version 1.0.27~pre{date} from my ppa repository

Many thanks for your report.

Hope this helps.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/sane-devel/attachments/20170509/e452a2c5/attachment.html>

More information about the sane-devel mailing list