[sane-devel] libsane-imagescan.so.1' (No such file or directory)

ToddAndMargo ToddAndMargo at zoho.com
Sun Feb 18 00:37:24 UTC 2018

On 02/17/2018 04:47 AM, Olaf Meeuwissen wrote:
> Hi,
> ToddAndMargo writes:
>> Hi All,
>> found 0 devices
>> What is this all about?
> How are we supposed to know?  

But, but, but, I thought you knew all and see all!!!
I should have put the question at the bottom of the post,
instead of the top.

> What did you do?  What did you expect to
> happen?  What happened?

I was unable to scan with saned.  I posted a link
to the full error log below.

> Please provide details.  We weren't shoulder-surfing at your place when
> this happened and we have neither extra-sensory perception capabilities
> nor crystal balls.

If you look at the bug report posted below, the two
attachments give tons of details.

>> Fedora 26 x 64
>> Xfce 4.12
>> sane-backends-1.0.27-9.fc27.x86_64
>> sane-backends-drivers-scanners-1.0.27-9.fc27.x86_64
>> sane-backends-drivers-cameras-1.0.27-9.fc27.i686
>> sane-backends-libs-1.0.27-9.fc27.i686
>> sane-backends-daemon-1.0.27-9.fc27.x86_64
>> sane-backends-drivers-scanners-1.0.27-9.fc27.i686
>> sane-backends-libs-1.0.27-9.fc27.x86_64
>> sane-backends-drivers-cameras-1.0.27-9.fc27.x86_64
>> I am trying to get xsane to work with systemd and saned.  When I run
>>       $ xsane net:localhost
>> I get the following error pop up:
>>      Error: Failed to open device `net:localhost': Error during device I/0
>> In saned at .service, I have debug set to the following:
>> Environment=SANE_CONFIG_DIR=/etc/sane.d SANE_DEBUG_DLL=255
>> And this error pops up in my debug log:
>> # journalctl -efx -t saned > saned.log.txt
>>      996: 032]: [dll] load: searching backend `imagescan' in
>> `/usr/lib64/sane'
>> Feb 17 02:59:12 rn4.rent-a-nerd.local saned[4032]: [dll] load: trying to
>> load `/usr/lib64/sane/libsane-imagescan.so.1'
>>      Feb 17 02:59:12 rn4.rent-a-nerd.local saned[4032]: [dll] load:
>> couldn't open `/usr/lib64/sane/libsane-imagescan.so.1' (No such file or
>> directory)
>>      Feb 17 02:59:12 rn4.rent-a-nerd.local saned[4032]: [dll] load:
>> couldn't find backend `imagescan' (No such file or directory)
>>      Feb 17 02:59:12 rn4.rent-a-nerd.local saned[4032]: [dll]
>> sane_get_devices: found 0 devices
>>      Feb 17 02:59:14 rn4.rent-a-nerd.local saned[4032]: saned exiting
> The dll backend not being able to load a backend should not prevent
> saned from detect locally connected devices at large.  Looks like you
> expect to find a device supported by the pixma backend.  If that's the
> case, you may safely remove/purge any imagescan package that you seem to
> have picked up from who knows where (EPSON's download site, perhaps?).
> Hope this helps,

Hi Olaf,

Where did you see pixma being call out?  Maybe???

Here is some more detailed information:

My scanner is an Epson Perfection V300

I installed iscan-gt-f720-bundle-1.0.1.x64.rpm from


I am able to scan with both xsane and simple-scan, which
both use the front end.

I am not able to scan from the back end using saned
with either "xsane net:localhost" or PDF Studio,
which only uses saned.

I am able to manually start saned and scan with
PDF Studio and "xsane net:localhost".  Well, some
of the time.

An unlimited trial of PDF Studio can be downloaded from

 From the error log, it looks like saned tried to contact
the scanners three times and failed because it could not
find libsane-imagescan.so.1

For the full error log, see

Error log: https://bugzilla.redhat.com/attachment.cgi?id=1397367
configuration: https://bugzilla.redhat.com/attachment.cgi?id=1397368


More information about the sane-devel mailing list