[sane-devel] Mustek scanner problem

Olaf Meeuwissen paddy-hack at member.fsf.org
Sun Feb 25 04:01:15 UTC 2018

Hi Chris,

Chris Widdows writes:

> Made the changes, but it is not recognised. XSane seems to only pickup
> on my webcam. I ran sane-find-scanner as root and this is what I got:
>> sane-find-scanner
>  # sane-find-scanner will now attempt to detect your scanner. If the
>  # result is different from what you expected, first make sure your
>  # scanner is powered up and properly connected to your computer.
>  # No SCSI scanners found. If you expected something different, make
> sure that
>  # you have loaded a kernel SCSI driver for your SCSI adapter.
> found USB scanner (vendor=0x138a, product=0x0011) at libusb:003:005
> found USB scanner (vendor=0x055f, product=0x050c, chip=GL128) at
> libusb:001:003
>  # Your USB scanner was (probably) detected. It may or may not be
> supported by
>  # SANE. Try scanimage -L and read the backend's manpage.
>  # Not checking for parallel port scanners.
>  # Most Scanners connected to the parallel port or other proprietary ports
>  # can't be detected by this program.
>> scanimage -L
> device `v4l:/dev/video0' is a Noname Integrated Camera virtual device

Was that run as root as well?  What does

 $ sudo SANE_DEBUG_DLL=128 scanimage -L

say?  Does the output look like it loaded that third-party backend
correctly?  It could be that the backend was installed someplace where
the dll backend does not look.  Not all third-party backends have been
fixed up to play nice with multiarch.

Before multiarch, backends were installed in

  /usr/lib/sane  (or /usr/lib64/sane)

After multiarch, they usually live in a place that looks like


> And this is LMDE2 distro, 64bits, kernel 4.9 (from the jessie
> backports). Essentially LMDE2 is a pimped Debian Jessie, which is
> oldstable. 16GB Ram, core i7, Disk is a 64GB ssd + 1TB HDD and the HDD
> is configured as a bcache-backend, because there's 192GB left on the
> ssd, which I use as the bcache cache device.
> Rgds Chris
> On 15/02/18 13:56, Olaf Meeuwissen wrote:
>> Hi Chris,
>> Chris writes:
>>> Hi,
>>> My first post here, and whilst I think I've covered the obvious things,
>>> I could have easily missed something. But I can read, so in case I
>>> missed what to read, kindly tell me....
>>> Having said that, I have got a Mustek A3F1200N scanner. It's an usb
>>> scanner and Mustek offers a xsane backend deb file for this scanner at
>>> ftp://ftp2.mustek.com.tw/pub/new/driver/A3F1200N/Linux/ . I run 64 bit
>>> LMDE2, so I downloaded and installed the .deb file. This added a lot of
>>> files to /etc/sane.d, but xsane does not detect the scanner. So I did an
>>> lsusb and found this: Bus 001 Device 010: ID 055f:050c Mustek Systems, Inc.
>> Third party backend binary packages often don't bother with getting the
>> device access permissions right on *your* particular system.  Taking a
>> quick look at Mustek's binaries, it doesn't seem to even do so much as
>> try.
>> # Apart from that, it seems to warp you back in time to sane-backends
>> # 1.0.23 for all other backends and clobber whatever changes you made
>> # to /etc/sane.d.  At least for the i386 deb.
>> You didn't mention the distribution you use but something like the below
>> ought to work for most.
>>  sudo cp /lib/udev/rules.d/*-libsane.rules /etc/udev/rules.d/
>> and replace the whole of the gargatuan list of entries that look like
>>   ATTRS{idVendor}=="055f", ATTRS{idProduct}=="050c", ENV{libsane_matched}="yes"
>> with that single line.  Replace the line that starts with
>>   ENV{libsane_matched}=="yes"
>> with
>>   ENV{libsane_matched}=="yes", RUN+="chmod 0666 $env{DEVNAME}"
>> Replug your device and things should work, if my recollection of the way
>> udev works still up to snuff.  It's not the most granular and security
>> conscious way of going about this but is good enough for single user
>> machines and most SOHO use.

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list