[sane-devel] Problem with SnapScan 1212u

ripero84 ripero84 at gmail.com
Sun Jan 21 15:59:02 UTC 2018

Hi Markus,

Thank you for your reply.

Yes, the users I was running scanimage/xsane from were members of the machine scanner 
group - I'm sorry I forgot to mention that.  All files in /etc/sane.d and /usr/share/sane 
are owned by root:root and have 644 permissions (755 for directories), as far as I can see.

I have now noticed that the output of lsusb related to iManufacturer, iProduct and Device 
Status (Bus/Self Powered) also seems to change over time, and earlier in the session they 
are correctly reported as AGFA, SNAPSCAN and Self Powered - see 
https://paste.debian.net/1006268/ for an example of how it changes.  If after those values 
become corrupted I disconnect both cables from the scanner and reconnect them again, it 
seems to go back to the initial situation (values are correct and error back to initial 
"Failed to open device [...] Error during device I/O."

Kind regards,


On Sun 21 Jan 2018 13:38 +0100, Markus Heiser <markus.heiser at darmarit.de> wrote:
> Hi JM,
> On 21.01.2018 13:13, ripero84 wrote:
>> Hello,
>> Apologies if this is the wrong list to ask for help with this issue.
> feel welcome
>> I have an old Agfa SnapScan 1212u which was working fine when connected to an old 
>> computer A.  A debian dist-upgrade went wrong on A, and all my attempts to scan since 
>> then have failed.
>> So far I have tried to scan from two newer computers (B, C) that run debian stable, as 
>> well as computer A running a very recent debian live CD.  In each of the computers I 
>> have tried attaching the USB cable to multiple ports.  I have also tried two different 
>> USB cables.
> did you add the user (with you run scannimage) to group scanner?
> Please compare the output of
>    $ groups
>    .. scanner ..
> from A with the ouput from B (and C)
> -- Markus --
>> I usually get an error of the form "Failed to open device `snapscan:libusb:001:008': 
>> Error during device I/O."  The exception is that, after I run (as user)
>> $ scanimage -L
>> device `snapscan:libusb:001:008' is a AGFA SNAPSCAN flatbed scanner
>> the error message changes to "no devices available" (but lsusb continues to list the 
>> device).
>> In each of the 3 systems, the SnapScan .bin driver I have always used has been copied to 
>> the /usr/share/sane/snapscan/ directory, and I have changed the firmware line of 
>> /etc/sane.d/snapscan.conf accordingly.
>> A sample output of lsusb -v -v can be found on https://paste.debian.net/1006235/ .  Some 
>> of the scanner lines (starting in line 979) show "(error)"s, and the device status is 
>> reported as bus powered, when the device is actually powered by being attached to the 
>> mains by a little provided transformer (and the device still makes the usual noise when 
>> it is powered on).
>> Am I missing something, or doing something wrong?  Is there any way I can make this 
>> scanner work again?
>> Thank you for your help.
>> Kind regards,
>>      JM

More information about the sane-devel mailing list