[sane-devel] canon lide 200 sane-backends-1.0.27 --res=300 issue

Robert A. Schmied uwppp at flash.net
Mon May 21 18:57:40 BST 2018

Olaf Meeuwissen wrote:
> Hi Robert,
> Robert A. Schmied writes:
>>aloha saners (and xsaners)
>>with both scanimage and xsane there appears to be an issue
>>with --resolution=300 for my canon canoscan lide 200.
>>with --resolution=300 --depth=8 and [ --mode=gray | --mode=line ]
>>the scan works ok.
>>however, with --resolution=300 --depth=8 --mode=color
>>the pixels are stretched in the +y direction and the scan
>>stops at about y_pixel 3294 (about 1/2 of sheet at  y-length 142 mm).
> Hmm, smells like the scanner expects different resolutions for x and y
> directions.  Does the backend expose --x-resolution and --y-resolution
> options?  If it does, using
>   --x-resolution=300 --y-resolution=600
> might solve your problem.

aloha Olaf and interested sane backenders:

unfortunately the genesys/genesys_gl847 does not accept --x-resolution.

/opt/csw/bin/scanimage: illegal option -- x-resolution=300
well now i checked and checked again that i prefixed -- to that option string
and yes i did -- kind of a poorly implemented error string message imnsho.

my complete command line:

   $    /opt/csw/bin/scanimage -x216 -y150   --mode=color --x-resolution=300 --y-resolution=600 \
   --format=pnm  2>/tmp/si_y150_g_300_pnm.log   >/tmp/scanout_y150_c_x300y600_pnm.pnm

i also tried various alternates like --x-res= and the like, to no avail.
i also tried --res=300 --y-resolution=600 also without success.

more problem discussion

while i have tried to read thru the genesys code as well as the sane architecture
description i have yet to get a good understanding of how the genesys sis
[software image system ???] actually works.  but it seems that something goes
wrong only when the mode is color and the resolution is 300.  as i said limited
testing at --res 600 in color mode works just fine and res < 300 are also fine.

from a black box (eg users perspective) at --res 300 in grey mode (which works
fine) the image sensor moves down the page with constant motion and motor sound.
but when the mode is color the image sensor motion is erratic, the motor stops
and starts.  note however the first say 1 inch [25 mm] of the y-scan is correct
(no obvious y pixel stretching) and the sensor motion and motor sounds are
constant.  after this first inch of y-travel the erratic motion and sound begins.

i tried various smaller and larger --buffer-size values (default is 32k bytes)
without any noticeable improvement.

i should probably announce that my antique equipment provides only notional
support for usb 2.0, so a slow usb might be part of my problem!?  my syslog
indicates the scanner is "operating at full speed".  i understand that in
usb 1.1 terms 'full speed' means 12 mbit/s.

i'm ready and willing to perform and post any diagnostics, code hacks, etc
on request and direction possibly with some but minimal guidance but within
the limits of my prehistoric equipment and operating system.



>>if i run a scan with 16 bit depth in --mode=gray the y pixel
>>stretching starts at y-length 82 mm.
>>very limited testing with --res=600 and higher does not show this
>>problem for any -y values.
> Hope this helps,
> --
> Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
>  GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
>  Support Free Software                        https://my.fsf.org/donate
>  Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list