[sane-devel] sane-find-scanner finds Canon Canoscan N24OU, scanimage -L does not

Louis Lagendijk louis at fazant.net
Thu Nov 1 21:49:41 GMT 2018

On Mon, 2018-10-29 at 00:27 -0400, Terry Spearman wrote:
> Hi Olaf,
> Yes, I tried running scanimage -L when logged on as root with the
> same result i.e. "No scanners were identified...."
> Since my original post I made an observation which may or may not be
> relevant. From the Centos 7.0 man page for plustek, 
> https://www.unix.com/man-page/centos/5/sane-plustek/
> /etc/sane.d/plustek.conf
> The backend configuration file
> /usr/lib64/sane/libsane-plustek.a
> The static library implementing this backend.
> /usr/lib64/sane/libsane-plustek.so
> The shared library implementing this backend (present on systems that
> support dynamic loading)."
> On my system I'm seeing /etc/sane.d/plustek.conf but /usr/lib64/sane
> is empty.  I've seen something somewhere that says if sane-find-
> scanner finds the scanner but scanimage -L does not it means that you
> don't have the right backend for the scanner installed.  Could a
> missing library file be the culprit?

If /usr/lib64/sane is empty you probbly don;t have sane-backends-
drivers-scanners installed: yum install sane-backends-drivers-scanners
should solve your problem....

BR, Louis
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20181101/68818111/attachment.html>

More information about the sane-devel mailing list