[sane-devel] sane-find-scanner finds Canon Canoscan N24OU, scanimage -L does not

Terry Spearman tnspearman at twc.com
Tue Nov 20 19:37:38 GMT 2018

M. Allan Noah wrote:


>From the release notes of our last release:

Note 3: The Linux USB3 workaround which was added in version 1.0.25 is now
disabled by default. If you have difficulty using a scanner which previously
worked, or intermittent scanner availability, try setting the new
environment variable SANE_USB_WORKAROUND=1 before starting your frontend.


I had previously seen that note, but I concluded from info on my motherboard
manufacture's website (Supermicro) that the back panel USB ports where 2.0,
and therefore the note was not relevant to my issue.  It turns out that I
was incorrect: based on 3.0 ports being blue and 2.0 ports being black, my
back panel has both.  However the scanner is plugged into a black (USB 2.0)
one.  Nonetheless, I rebooted the server, ran export SANE_USB_WORKAROUND=1,
export SANE_DEBUG_PLUSTEK=128, and then scanimage -L.  I got the same
results as previously, i.e. scanner not ready,  However, unlike previous
results, when I ran scanimage -L a second time it still apparently found the
scanner, and there was no "scanner not ready" message in the debug file.  I
then ran scanimage with a filename to direct the results into, and it seems
to have worked; I heard the scanner doing it's thing and there are multiple
new files in my home directory.


I haven't figured out how to view the image file yet, or move it over the
network to where I need it to be, but it appears that my immediate problem
is solved.  Thanks to everyone for their patience and useful suggestions.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20181120/07e80995/attachment.html>

More information about the sane-devel mailing list