[sane-devel] invalid argument using in spite using SANE scanner or image acquisition device

Andreas Moroder andreas.moroder at gmx.net
Sun Sep 16 08:15:42 BST 2018


I use SuSE 42.3 64 bit with kernel 4.4.143-65-default #1 SMP and
sane-backend 1.0.24

It worked well for long time, but since beginning of September I get a
invalid argument error.

scanimage -L


device `pixma:MX920_192.168.1.66' is a CANON Canon PIXMA MX920 Series
multi-function peripheral

but when I try to scan I get

scanimage --device="pixma:MX920_192.168.1.66" --format=TIFF > x.tiff
scanimage: open of device pixma:MX920_192.168.1.66 failed: Invalid argument

I have no active firewall.

On my wifes laptop ( also SuSE ) we get the same error.

I suppose a SuSE update caused this but I don't know what config files I
should check or change.

The is one other thing that changed the last weeks. We changed internet
provider and now we have also IPV6.

On the other side printing works well with the same pixma MFC.

It would be nice if someone could help me



More information about the sane-devel mailing list