[sane-devel] Canon LiDE 300 found but not working

Chris Bare chris.bare at gmail.com
Fri Mar 22 18:26:32 GMT 2019

I'm running Ubuntu 18.04 and I just bought a Canon LiDE 300 scanner.
I tried getting it to work with the sane packages from Ubuntu, but they
were pretty old, so I grabbed the source and built it. With the latest I
get a little further, but I still get the same error when I try to scan.
I installed the Canon program and it works fine. I noticed they installed
some udev rules in /etc/udev/rules.d. My make install put the sane rules in
/lib/udev/rules.d. I tried removing the canon rules and running:
sudo udevadm control --reload-rules && udevadm trigger

But the results are the same.
Here are various commands I've tried:
% sane-find-scanner -q
found USB scanner (vendor=0x04a9 [Canon], product=0x1913 [LiDE 300]) at
found USB scanner (vendor=0x0e8d, product=0x000e) at libusb:003:022
% scanimage -V
scanimage (sane-backends) 1.0.27git; backend version 1.0.27

% scanimage -L         #this failed until I installed the latest
device `pixma:04A91913_40A0B5' is a CANON CanoScan LiDE 300 multi-function
% scanimage > out
scanimage: open of device pixma:04A91913_40A0B5 failed: Invalid argument

Any suggestions appreciated.

Chris Bare
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20190322/e147c5a8/attachment.html>

More information about the sane-devel mailing list