[sane-devel] Canon ImageClass MF644Cdw

Louis Lagendijk louis at fazant.net
Fri Nov 1 21:52:50 GMT 2019

On Fri, 2019-09-13 at 21:40 -0400, Kip Shaffer wrote:
> Scanning Results!  I updated to today's version: 1.0.28+git20190913-
> bionic0
> Using Simple Scan I was able to scan at 75, 150, 300, 600, 1200, and
> 2400 dpi in both Text and Photo modes.  Perfect!
> When scanning from the document feeder, it scans front and back, one
> sheet or many, but after the job is done there is a pause, and then
> it says "Error communicating with scanner". 
> Also, this has all been through USB.  I tried to connect with the
> network and scanimage -L cannot find it.  I added the address to
> pixma.conf (neither line helped):
> bjnp://MF640_192.168.1.97
> bjnp://

Apologies for the late reply: have been too busy with my new server
lately, so I only got back to sane/ bjnp this week
As the  MF644Cdw is a laserjet, it does not use bjnp as all laserjets
use mfnp as protocol. This is almost identical to bjnp but uses a
different port and has a few deviations. The bjnp code supports mfnp as
well, just change the bjnp in bjnp://MF640_192.168.1.97 to mfnp://....

The backend should normally detect the scanner when computer and
scanner are on the same subnet. I have never worked with a laserjet
myself (wrote the code while testing over a tunnel to  are remote
device in Canada (I am in Europe).....
I seem to recall that there is a switch or something similar that needs
to be activated for network based scanning.

Now Canon may have dropped mfnp from the laserjet series completely
like they are doing with bjnp for the inkjets. Can you try to see what
the scanner advertises with something like "avahi-browse -a" (press
control-c after a few seconds)?

best regards, Louis
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20191101/ec56b6b6/attachment.html>

More information about the sane-devel mailing list