[sane-devel] libusb not available

Tom Buckler tom at buckler.ca
Tue Feb 11 16:28:34 GMT 2020

Thanks Olaf


> On Feb 11, 2020, at 1:00 AM, Olaf Meeuwissen <paddy-hack at member.fsf.org> wrote:
> Hi Tom,
> Tom Buckler writes:
>> Hello,
>> I am wanting to install a new instance of sane on OSX:
>> When I go to
>> $ ./configure BACKENDS="fujitsu"
>> I get
>> *** Warning: sane-backends will be built without USB support.  There may
>> Yet libusb is installed via homebrew:
>> taws27 on TAWS27: /usr/local/lib$ ls -l libusb*
>> lrwxr-xr-x  1 taws27  admin  46 10 Feb 23:16 libusb-1.0.0.dylib -> ../Cellar/libusb/1.0.23/lib/libusb-1.0.0.dylib
>> lrwxr-xr-x  1 taws27  admin  40 10 Feb 23:16 libusb-1.0.a -> ../Cellar/libusb/1.0.23/lib/libusb-1.0.a
>> lrwxr-xr-x  1 taws27  admin  44 10 Feb 23:16 libusb-1.0.dylib -> ../Cellar/libusb/1.0.23/lib/libusb-1.0.dylib
>> Thoughts appreciated,
> Please run `./configure --with-usb BACKENDS=fujitsu` and send the
> `config.log` file to the list.  You may want to compress the file
> as large messages end up in the moderator queue.

Well that at least let me know that there was a problem with USB:
	"configure: error: USB support requested but required libraries not found."
But that's fixed with pkg-config (below)

> That is not a problem per se, but it slows down communication.
> Even when compressed, the message may be too large.
> Alternatively, you could create an issue for this at
>  https://gitlab.com/sane-project/backends/issues/new
> I don't have access to any MacOS systems, so can only really debug
> this via that log file.

I could fix that.

> That said, do you have `pkg-config` installed?  If not, that is most
> likely why libusb is not detected.

Didn't know about that one — it WORKED! THANKS!

> Apologies but we don't see many MacOS folks around here

I'm used to that ;)

> so our build
> instructions may be lacking a bit for that OS.

um, are there _any_ OSX specific instructions? If so I've totally missed them all these years that I've been relying on SANE :)

> Hope this helps,
> --
> Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
> GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
> Support Free Software                        https://my.fsf.org/donate
> Join the Free Software Foundation              https://my.fsf.org/join

So I'm past ./configure,  Now I get the following error from MAKE:

~/Downloads/sane-backends-1.0.29-116-g336cbdfd$ sudo make
	mv -f $depbase.Tpo $depbase.Plo
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I../include/sane -D_REENTRANT -DPATH_SANE_CONFIG_DIR=/usr/local/etc/sane.d -DPATH_SANE_DATA_DIR=/usr/local/share -DPATH_SANE_LOCK_DIR=/usr/local/var/lock/sane -DV_MAJOR=1 -DV_MINOR=0 -I. -I. -I../include -I../include -I/usr/local/Cellar/libusb/1.0.23/include/libusb-1.0 -I/usr/include/libxml2 -Wall -Wextra -pedantic -g -O2 -MT sanei_usb.lo -MD -MP -MF .deps/sanei_usb.Tpo -c sanei_usb.c  -fno-common -DPIC -o .libs/sanei_usb.o
sanei_usb.c:67:10: fatal error: 'libxml/tree.h' file not found
#include <libxml/tree.h>
1 error generated.
make[1]: *** [sanei_usb.lo] Error 1
make: *** [all-recursive] Error 1

This is specific to 1.0.29, as I tried 1.0.28 and it continues to install OK, (but I have to add my scanner to fujitsu.conf.) I'd still like to try to fix this in 1.0.29.


Tom Buckler | Buckler Microelectronics Inc.
17008 - 90 Avenue NW | Suite 272 | Edmonton | AB | Canada | T5T 1L6
Cell: (780) 499-5525 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20200211/14b2e682/attachment.html>

More information about the sane-devel mailing list