[sane-devel] Canon TR8520 will print but not scan

Tim Schoell schoelta at gmail.com
Tue Jun 2 01:41:26 BST 2020

I am fairly new to Linux.  I"m running Ubuntu 20.04.  I can get you the 
hardware detail if you need, but you'll have to tell me how.

I have having trouble getting my new Canon TR8520 to scan.  It prints 
just fine, but I can't get my computer to recognize the scanner.  I've 
tried both WIFI, and directly connecting with a USB cable, and nothing.  
This is the version of the SANE backend I have installed:  scanimage 
(sane-backends) 1.0.25git; backend version 1.0.30

I've tried many ways to edit the pixma.conf file to manually enter the 
address of my scanner, but nothing works.  In fact, I get he following 
errors when I run scanimage -L:

[19:38:55.493124] [bjnp] udp_command: ERROR - no data received
[19:38:55.493269] [bjnp] bjnp_init_device_structure: Cannot read mac 
address, skipping this scanner
[19:39:07.504136] [bjnp] udp_command: ERROR - no data received
[19:39:07.504216] [bjnp] add_scanner: ERROR - Cannot read scanner make & 
model: bjnp:// is the address I get from my printer for it's location.

Any help would be GREATLY appreciated.

Tim Schoell
We are LIVING like no one else, so that later we can LIVE like no one else.


More information about the sane-devel mailing list