[sane-devel] Net Client Not Contacting Server

Olaf Meeuwissen paddy-hack at member.fsf.org
Sun Sep 6 06:57:18 BST 2020


C. Cook writes:

> On 2020-09-02 08:35, C. Cook wrote:
>> Scanner is an Epson Perfection V370. I have IScan installed on server
>> and client.
>> Have saned running on the server, listening on ipv4 *:6566. scanimage
>> -L does see the scanner.
>> On the client in dll.conf I have all commented out except net. In
>> net.conf I have:
>> scan-server

Does the scan-server hostname resolve?

>> In dll.d there is iscan which contains:
>> epkowa
>> net

This is on the server, right?  Because its the server that communicates
with the device via the epkowa backend.

>> On the client when I run scanimage -L it does not see the scanner.
>> When I run tcpdump on the client watching port 6566, and then do
>> scanimage -L, tcpdump never sees 6566 anywhere. So the client is
>> definitely not reaching out to the net for the server.

The 6566 port is the target port on the server.  You'd want to run
tcpdump there if at all.  Why don't you start saned in debug mode
on the server to see what's going on?

You can also enable debugging of the net backend on the client side

  SANE_DEBUG_NET=128 scanimage -L

>> In dll.conf I have enabled epkowa along with net, but no change.
>> No idea what I'm doing wrong.
> No one has any idea?

A few more things to check:

 - Is there a firewall between the client and server programs that block

 - Does the saned process on the server allow communication from your
   client (check /etc/hosts.allow and /etc/hosts.deny as well as your

Hope this helps,
Olaf Meeuwissen, LPIC-2            FSF Associate Member since 2004-01-27
 GnuPG key: F84A2DD9/B3C0 2F47 EA19 64F4 9F13  F43E B8A4 A88A F84A 2DD9
 Support Free Software                        https://my.fsf.org/donate
 Join the Free Software Foundation              https://my.fsf.org/join

More information about the sane-devel mailing list