[sane-devel] Problem with new Canon iSensys MF746Cx

Andrea Croci andrea.croci at gmx.de
Tue Sep 8 05:20:19 BST 2020


I have just installed a new Canon iSensys MF746Cx on Ubuntu 18.04 and I
can't get it to scan. It' connected over the network. I haven't found
any driver or software for scanning on Canon's Website, so I was hoping
I could do it with sane. I have read on the list of supported devices
that the MF741/743 are fully supported by the pixma backend.

So I activated the pixma backend in /etc/sane.d/dll.conf by uncommenting
it and edited the /etc/sane.d/pixma.conf file by adding
"bjnp://address.here:8612". Scanimage -L gives me this message:

[bjnp] udp_command: ERROR - no data received (timeout = 5000)
[bjnp] bjnp_init_device_structure: Cannot read mac address, skipping
this scanner
[bjnp] udp_command: ERROR - no data received (timeout = 5000)
[bjnp] add_scanner: ERROR - Cannot read scanner make & model:

Because CUPS adds the printer with the ipp protocol on port 631, I tried
with other things as well (port 631, ipp protocol, net) but I always get
the same error messages.

My Epson WF7620 works great with both the "epson2" and the "epkowa"

Any help would be appreciated. Thank you.

More information about the sane-devel mailing list