[sane-devel] Fwd: HP ScanJet Pro 2000 sudden failure

Ellis Cohen ellis_cohen at pobox.com
Wed Mar 3 23:12:21 GMT 2021

I can add that I just tried the older Canon scanner -- CanoScan N1220U -- and it also immediately displays the same error message (Failed to  open device ...).

Advice/suggestions please.

Ellis Cohen

----- Original message -----
From: Ellis Cohen <ellis_cohen at pobox.com>
To: sane-devel at alioth-lists.debian.net
Subject: HP ScanJet Pro 2000 sudden failure
Date: Wednesday, March 03, 2021 3:05 PM

I'm running Fedora 33, and have an HP ScanJet Pro 2000 s2 scanner (in addition to an older Canon scanner).
It was working fine until I just installed the latest updates from the Fedora repositories.
After the updates,
 * 'scanimage -L' finds the scanner
 * 'sane-find-scanner' finds the scanner
 * xsane offers me the choice of which scanner -- but if I select the HP, I immediately get the error message
Failed to open device `hpaio:/usr/HP_ScanJet_Pro_2000_s2?serial=xxx':  Error during device I/O

Version info:

xsane --
 * xsane-0.999 (c) 1998-2013 Oliver Rauch
 * package xsane-0.999
 * compiled with GTK-2.24.32

dnf reports
 * Package libsane-hpaio-3.21.2-1.fc33.x86_64 is already installed.

Any suggestions as to how I can restore functionally using this scanner?


Ellis Cohen
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://alioth-lists.debian.net/pipermail/sane-devel/attachments/20210303/008154e8/attachment.htm>

More information about the sane-devel mailing list