[sane-devel] Epson Perfection1640: Operation not supported

ael witwall3 at disroot.org
Tue Oct 5 10:27:58 BST 2021

On Mon, Oct 04, 2021 at 08:39:58PM +0100, ael via sane-devel wrote:
> On Mon, Oct 04, 2021 at 05:32:29PM +0200, Wolfram Sang wrote:
> > There is a PPA with the latest development version here if you want to
> > test right away:
> > 
> > https://launchpad.net/~sane-project/+archive/ubuntu/sane-git
> > 
> I have tried using the ubuntu debs, but hit
> dpkg: dependency problems prevent configuration of sane-utils:
>  sane-utils depends on libjpeg8 (>= 8c); however:
>   Package libjpeg8 is not installed.

Just to report further: I tried to install the ubuntu libjpeg8
but then hit further problems:
libjpeg8:amd64 depends on libjpeg-turbo8

I then added libjpeg-turbo8_2.0.6-0ubuntu2_amd64.deb
but then:
error processing archive libjpeg-turbo8_2.0.6-0ubuntu2_amd64.deb (--install):
 conflicting packages - not installing libjpeg-turbo8:amd64

It seems that debian has instead:

So Ubuntu and debian seem to be using different package names. I could
probably sort all this out if I had the time to refresh my memory
about packaging. But is does not seem to be straight forward to
use the Ubuntu packages in Debian.

Meanwhile, I will get my scanner out and retest: despite the broken
packages, I think there is a chance that it might now work.


More information about the sane-devel mailing list