[sane-devel] HP Scanjet 7650 (hp5590 backend) inserts ghost pages when using "ADF Duplex"

hm hansmobile25 at gmail.com
Wed Feb 9 15:12:02 GMT 2022


I am using a Scanjet 7650 in the "ADF Duplex" mode and I have noticed it 
inserts "ghost" blank pages at random.

My setup:

Using a 2 sheets/4 pages document in the ADF, I scan with:

$ scanadf \
   --device-name hp5590 \
   --source "ADF Duplex" \
   -x 210.0 -y 297.0 \
   --mode Gray \
   --resolution 300 \
   --output-file /tmp/file-%04d.pnm \

And more often that not, it will insert a ghost blank page between the 
two sheets (i.e. between page 2 and page 3).

Same thing if using --start-count 1 --end-count 4; page 3 will be a 
"ghost blank" and page 4 is the actual page 3 (actual page 4 is dropped 
altogether in this case).

I have also tried scanimage in batch mode with the same result:

$ scanimage \
   --batch \
   --device-name hp5590 \
   --source "ADF Duplex" \
   -x 210.0 -y 297.0 \
   --mode Gray \
   --resolution 300 \

Here are the versions I'm using on Mint 20.3:

$ scanimage --version
scanimage (sane-backends) 1.0.32; backend version 1.0.29

$ scanadf --version
scanadf (sane-frontends) 1.0.14

Any idea what I might be doing wrong? Or how can I assist in squashing 
the bug?


More information about the sane-devel mailing list