[sane-devel] Xsane problems with a Brother ADS-1200 scanner.

Brian b_lists at patandbrian.org
Mon Jul 3 14:09:06 BST 2023

Hi all,

I'm looking for some assistance with a Brother ADS-1200 scanner 
attached to a PC running Linux Mint V21 LTS, all patches applied.

The scanner *used* to work last time I used it, but it's possible that 
may have been under an earlier version of Mint. My next step is to try 
downgrading the operating system (booting an old image from a key 
drive) but I thought I would ask here first.

I've tried both Brother "support" - their response was "We can't 
reproduce it, it must be your computer" - and posting on the Mint 
support forums, which didn't produce any resolution to the problem.

I've tried both swapping out the USB cable and changing the USB port, 
and I've also tried reinstalling both Xsane (v0.999-11ubuntu1) and 
simple-scan (v42.0.1). I'm including the simple-scan details here 
purely as additional information, I know this is a sane-related list.

Both XSane and simple-scan identify the scanner as being connected, 
and function exactly as expected right up until the point when I 
actually hit the button to start a scan. When I do that, XSane 
immediately returns an error message "Failed to start scanner: Invalid 
argument", and simple-scan immediately returns a messge "Failed to 
scan. Unable to start scan".

Short of stepping back through the disk images I have of Mint until I 
find one that works, I am out of ideas. I don't have any kind of 
access to a Windows PC and I'm in a remote part of Maine, the only 
people I know with computers within 30 miles are running either Linux 
or whatever it is that Apple systems use.

Can anybody offer any ideas? If you need additional information about 
my system, just ask.



More information about the sane-devel mailing list