<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>
<body dir="auto">
👍🏻👍🏻<br>
<div dir="ltr"><br>
Il giorno 2 apr 2019, alle ore 07:25, Tony Kinyua <<a href="mailto:tony@kysh.me.ke">tony@kysh.me.ke</a>> ha scritto:<br>
<br>
</div>
<blockquote type="cite">
<div dir="ltr">Hello,
<div class=""><br class="">
</div>
<div class="">An update. </div>
<div class=""><br class="">
</div>
<div class="">Restored my Mac from a Time Machine backup then did the upgrade to 10.14.4 again. This time round I have not experienced any issues so far.</div>
<div class=""><br class="">
</div>
<div class="">Regards</div>
<div class="">Tony<br class="">
<div><br class="">
<blockquote type="cite" class="">
<div class="">On 31 Mar 2019, at 15:37, Tony Kinyua <<a href="mailto:tony@kysh.me.ke" class="">tony@kysh.me.ke</a>> wrote:</div>
<br class="Apple-interchange-newline">
<div class="">
<div style="word-wrap: break-word; -webkit-nbsp-mode: space; line-break: after-white-space;" class="">
Hello,
<div class=""><br class="">
</div>
<div class="">Rather than cross post, I have opened a macports ticket</div>
<div class=""><br class="">
</div>
<div class=""><a href="https://trac.macports.org/ticket/58274" class="">https://trac.macports.org/ticket/58274</a></div>
<div class=""><br class="">
</div>
<div class="">Will update this end if I get a solution.</div>
<div class=""><br class="">
</div>
<div class="">Regards</div>
<div class="">Tony<br class="">
<div class=""><br class="">
<blockquote type="cite" class="">
<div class="">On 30 Mar 2019, at 15:50, Tony Kinyua <<a href="mailto:tony@kysh.me.ke" class="">tony@kysh.me.ke</a>> wrote:</div>
<br class="Apple-interchange-newline">
<div class="">
<div class="">Hi Umberto,<br class="">
<br class="">
Open a new thread and I will walk you through my setup and how I got it working before the upgrade. You can CC me in the new thread. Please don’t reply to this one unless specifically addressing the dbus, avahi issue etc that am experiencing.<br class="">
<br class="">
Regards<br class="">
Tony<br class="">
<br class="">
<blockquote type="cite" class="">On 30 Mar 2019, at 13:32, Umberto Cerrato <<a href="mailto:umbertocerrato@outlook.it" class="">umbertocerrato@outlook.it</a>> wrote:<br class="">
<br class="">
So many “too”s.<br class="">
<br class="">
Anyway I tried just now. I’m getting my usual error (“device […] is not configured”). So, again, unfortunately I cannot help you :/<br class="">
<br class="">
Keep us updated.<br class="">
<br class="">
Best<br class="">
<br class="">
<blockquote type="cite" class="">Il giorno 30 mar 2019, alle ore 11:27, Umberto Cerrato <<a href="mailto:umbertocerrato@outlook.it" class="">umbertocerrato@outlook.it</a>> ha scritto:<br class="">
<br class="">
Hi,<br class="">
<br class="">
Yes, you are right. I’m sorry.<br class="">
<br class="">
<blockquote type="cite" class="">Il giorno 30 mar 2019, alle ore 11:21, Tony Kinyua <<a href="mailto:tony@kysh.me.ke" class="">tony@kysh.me.ke</a>> ha scritto:<br class="">
<br class="">
Hi Umberto,<br class="">
<br class="">
I would suggest you start another thread with your particular issues so that we can separate it from mine. I will be glad to assist where I can.<br class="">
<br class="">
Regards<br class="">
Tony<br class="">
<br class="">
<blockquote type="cite" class="">On 30 Mar 2019, at 12:56, Umberto Cerrato <<a href="mailto:umbertocerrato@outlook.it" class="">umbertocerrato@outlook.it</a>> wrote:<br class="">
<br class="">
Hi Tony,<br class="">
<br class="">
I tried but it didn’t work. I’m giving it another try today.<br class="">
Thank you.<br class="">
<br class="">
Best,<br class="">
Umberto <br class="">
<br class="">
<blockquote type="cite" class="">Il giorno 30 mar 2019, alle ore 08:55, Tony Kinyua <<a href="mailto:tony@kysh.me.ke" class="">tony@kysh.me.ke</a>> ha scritto:<br class="">
<br class="">
<br class="">
<br class="">
<blockquote type="cite" class="">On 30 Mar 2019, at 02:34, Umberto Cerrato <<a href="mailto:umbertocerrato@outlook.it" class="">umbertocerrato@outlook.it</a>> wrote:<br class="">
<br class="">
Hi Tony.<br class="">
<br class="">
Unfortunately I cannot help you, since I never had this error.<br class="">
But I take the chance to ask you how did you installed sane-backends on macOS?<br class="">
</blockquote>
Umberto,<br class="">
<br class="">
I use sane-backends via the Macports environment (<a href="https://www.macports.org/" class="">https://www.macports.org</a>). I believe sane-backends should also be available via  Homebrew though I don’t use that environment (<a href="https://formulae.brew.sh/formula/sane-backends" class="">https://formulae.brew.sh/formula/sane-backends</a>).<br class="">
<br class="">
In my case its a simple command to have sane-backends installed<br class="">
<br class="">
sudo port install sane-backends<br class="">
<br class="">
Regards<br class="">
Tony<br class="">
<blockquote type="cite" class=""><br class="">
Please, I really need it. And many people are in need too.<br class="">
<br class="">
Thank you in advance<br class="">
Umberto<br class="">
<br class="">
Inviato da iPhone<br class="">
<br class="">
<blockquote type="cite" class="">Il giorno 30 mar 2019, alle ore 00:29, Tony Kinyua <<a href="mailto:tony@kysh.me.ke" class="">tony@kysh.me.ke</a>> ha scritto:<br class="">
<br class="">
Hello,<br class="">
<br class="">
I have an issue with sane on Mac OS. The setup was previously working (net) perfectly but yesterday after upgrading to Version 10.14.4 (18E226) (Mojave) xsane and scanimage are crashing immediately after being started with the following error.<br class="">
<br class="">
</blockquote>
</blockquote>
</blockquote>
</blockquote>
</blockquote>
<br class="">
Trying to taking the discussion back to the main issue…<br class="">
<br class="">
I’m on macOS 10.14.4 (18E226) too. I installed sane-backends too (MacPorts). I’ll let you if I’m getting the same error too.<br class="">
<br class="">
<blockquote type="cite" class="">
<blockquote type="cite" class="">
<blockquote type="cite" class="">
<blockquote type="cite" class="">
<blockquote type="cite" class="">bash-3.2$ scanimage -L<br class="">
dbus[57659]: Dynamic session lookup supported but failed: launchd did not provide a socket path, verify that org.freedesktop.dbus-session.plist is loaded!<br class="">
<br class="">
After setting up debug more information is provided.<br class="">
<br class="">
bash-3.2$ SANE_DEBUG_NET=3 scanimage -L<br class="">
[sanei_debug] Setting debug level of net to 3.<br class="">
[net] sane_init: authorize != null, version_code != null<br class="">
<br class="">
[net] net_avahi_init: could not create Avahi client: Memory exhausted<br class="">
[net] net_avahi_init: Avahi init failed, support disabled<br class="">
[net] sane_init: SANE net backend version 1.0.14 (AF-indep+IPv6) from sane-backends 1.0.27<br class="">
[net] sane_init: Client has little endian byte order<br class="">
[net] sane_init: searching for config file<br class="">
[net] sane_init: done reading config<br class="">
[net] sane_init: evaluating environment variable SANE_NET_HOSTS<br class="">
[net] sane_init: evaluating environment variable SANE_NET_TIMEOUT<br class="">
[net] sane_init: done<br class="">
[net] sane_get_devices: local_only = 0<br class="">
[net] sane_get_devices: finished (0 devices)<br class="">
<br class="">
No scanners were identified. If you were expecting something different,<br class="">
check that the scanner is plugged in, turned on and detected by the<br class="">
sane-find-scanner tool (if appropriate). Please read the documentation<br class="">
which came with this software (README, FAQ, manpages).<br class="">
[net] sane_exit: exiting<br class="">
[net] sane_exit: finished.<br class="">
<br class="">
Anyone come across this issue?<br class="">
<br class="">
Regards<br class="">
Tony<br class="">
<br class="">
<br class="">
<br class="">
<br class="">
-- <br class="">
sane-devel mailing list: <a href="mailto:sane-devel@alioth-lists.debian.net" class="">
sane-devel@alioth-lists.debian.net</a><br class="">
<a href="https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/sane-devel" class="">https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/sane-devel</a><br class="">
Unsubscribe: Send mail with subject "unsubscribe your_password"<br class="">
      to <a href="mailto:sane-devel-request@lists.alioth.debian.org" class="">sane-devel-request@lists.alioth.debian.org</a><br class="">
</blockquote>
</blockquote>
</blockquote>
</blockquote>
</blockquote>
</blockquote>
<br class="">
</blockquote>
<br class="">
<br class="">
-- <br class="">
sane-devel mailing list: <a href="mailto:sane-devel@alioth-lists.debian.net" class="">
sane-devel@alioth-lists.debian.net</a><br class="">
<a href="https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/sane-devel" class="">https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/sane-devel</a><br class="">
Unsubscribe: Send mail with subject "unsubscribe your_password"<br class="">
            to <a href="mailto:sane-devel-request@lists.alioth.debian.org" class="">
sane-devel-request@lists.alioth.debian.org</a></div>
</div>
</blockquote>
</div>
<br class="">
</div>
</div>
-- <br class="">
sane-devel mailing list: <a href="mailto:sane-devel@alioth-lists.debian.net" class="">
sane-devel@alioth-lists.debian.net</a><br class="">
<a href="https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/sane-devel" class="">https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/sane-devel</a><br class="">
Unsubscribe: Send mail with subject "unsubscribe your_password"<br class="">
            to <a href="mailto:sane-devel-request@lists.alioth.debian.org">sane-devel-request@lists.alioth.debian.org</a></div>
</blockquote>
</div>
<br class="">
</div>
</div>
</blockquote>
<blockquote type="cite">
<div dir="ltr"><span>-- </span><br>
<span>sane-devel mailing list: <a href="mailto:sane-devel@alioth-lists.debian.net">
sane-devel@alioth-lists.debian.net</a></span><br>
<span><a href="https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/sane-devel">https://alioth-lists.debian.net/cgi-bin/mailman/listinfo/sane-devel</a></span><br>
<span>Unsubscribe: Send mail with subject "unsubscribe your_password"</span><br>
<span>            to <a href="mailto:sane-devel-request@lists.alioth.debian.org">
sane-devel-request@lists.alioth.debian.org</a></span></div>
</blockquote>
</body>
</html>