[DSE-Dev] Bug#660345: policycoreutils: failed on upgrade from squeeze

Wookey wookey at debian.org
Mon May 28 10:24:31 UTC 2012

Package: policycoreutils
Version: 2.1.10-1
Followup-For: Bug #660345

I just got the same problem as #662772:
Setting up policycoreutils (2.1.10-1) ...
update-rc.d: /etc/init.d/policycoreutils exists during rc.d purge (use
-f to force)
dpkg: error processing policycoreutils (--configure):
 subprocess installed post-installation script returned error exit
status 1
dpkg: dependency problems prevent configuration of
 selinux-policy-default depends on policycoreutils (>= 2.1.0); however:
   Package policycoreutils is not configured yet.
This was upgrading from a pretty-much standard install of squeeze on a
netbook (aspire one), so I worry that this will be a common issue in
such upgrades. 

I see you have had trouble reproducing. 

My aptitude log has:
Aptitude log report
Sat, Oct  9 2010 00:14:26 +0100
/var/log/aptitude.1.gz:[UPGRADE] policycoreutils 2.0.82-1 -> 2.0.82-3

/var/log/aptitude.2.gz:[UPGRADE] policycoreutils 2.0.49-8 -> 2.0.82-1

which suggests the old version was installed fine, quite some time ago
(this machine has been sat on a shelf for 18 months)

I'm sure I never edited the /etc/init.d/policycoreutils file:
$ ls -l /etc/init.d/policycoreutils 
-rwxr-xr-x 1 root root 2731 Apr  4  2010 /etc/init.d/policycoreutils

Is there anything else I should check?

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages policycoreutils depends on:
ii  libaudit0         1:1.7.18-1.1
ii  libc6             2.13-32
ii  libcap2           1:2.22-1
ii  libdbus-1-3       1.5.12-1
ii  libdbus-glib-1-2  0.98-1
ii  libglib2.0-0      2.32.3-1
ii  libpam0g          1.1.3-7.1
ii  libpcre3          1:8.30-5
ii  libselinux1       2.1.9-2
ii  libsemanage1      2.1.6-2
ii  libsepol1         2.1.4-3
ii  lsb-base          4.1+Debian3
ii  psmisc            22.16-1
ii  python            2.7.2-10
ii  python-selinux    2.1.9-2
ii  python-semanage   2.1.6-2
ii  python-sepolgen   1.1.5-3
ii  python-support    1.0.14

Versions of packages policycoreutils recommends:
iu  selinux-policy-default  2:2.20110726-3

Versions of packages policycoreutils suggests:
pn  selinux-policy-dev  <none>

-- no debconf information

More information about the SELinux-devel mailing list