[DSE-Dev] Bug#734193: selinux-policy-default: cannot get security labeling handle: No such file or directory

Alberto Fuentes pajaro at gmail.com
Sat Jan 4 19:54:56 UTC 2014

Package: selinux-policy-default
Version: 2:2.20131214-1
Followup-For: Bug #734193

what do you know, same error on a container trying to upgrade from wheezy to
sid (from squeeze to wheezy it worked alright)

root at sid:/# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following NEW packages will be installed:
  iproute2 libarchive-extract-perl libatm1 libaudit-common libaudit1 liblog-
message-simple-perl libmodule-pluggable-perl libpcre3 libpod-latex-perl
  libprocps3 libterm-ui-perl libtext-soundex-perl libxtables10 sysvinit-core
The following packages will be upgraded:
  apt base-passwd bsdutils dash debconf-i18n dialog diffutils e2fslibs
e2fsprogs findutils gcc-4.4-base gcc-4.7-base gnupg gpgv grep gzip hostname
  initscripts iproute isc-dhcp-client isc-dhcp-common krb5-locales libacl1
libapt-pkg4.12 libblkid1 libbsd0 libbz2-1.0 libclass-isa-perl libcomerr2
  libedit2 libgdbm3 libgpm2 libgssapi-krb5-2 libk5crypto3 libkeyutils1
libkrb5-3 libkrb5support0 liblocale-gettext-perl libmount1 libncurses5
  libpam-modules libpam-modules-bin libpam-runtime libpam0g libprocps0
libselinux1 libsemanage-common libsemanage1 libsepol1 libslang2 libss2
  libstdc++6 libtext-charwidth-perl libtext-iconv-perl libtinfo5 libui-dialog-
perl libusb-0.1-4 libuuid1 lsb-base mount multiarch-support ncurses-base
  ncurses-bin ncurses-term net-tools netbase openssh-client openssh-server perl
perl-base perl-modules procps sed sysv-rc sysvinit sysvinit-utils tar tzdata
  util-linux vim vim-common vim-runtime zlib1g
87 upgraded, 14 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/34.9 MB of archives.
After this operation, 10.6 MB of additional disk space will be used.
Do you want to continue [Y/n]?
debconf: delaying package configuration, since apt-utils is not installed
dpkg: error processing archive
/var/cache/apt/archives/dash_0.5.7-3+nmu1_amd64.deb (--unpack):
 cannot get security labeling handle: No such file or directory
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.11-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages selinux-policy-default depends on:
ii  libpam-modules   1.1.3-9
ii  libselinux1      2.2.1-1
ii  libsepol1        2.2-1
ii  policycoreutils  2.2.5-1
ii  python           2.7.5-5
ii  selinux-utils    2.2.1-1

Versions of packages selinux-policy-default recommends:
ii  checkpolicy  2.2-1
ii  setools      3.3.8-3

Versions of packages selinux-policy-default suggests:
pn  logcheck        <none>
ii  syslog-summary  1.14-2

-- Configuration Files:
/etc/selinux/default/modules/active/file_contexts.local [Errno 13] Permission denied: u'/etc/selinux/default/modules/active/file_contexts.local'

-- debconf-show failed

More information about the SELinux-devel mailing list