[Soc-coordination] Report from Arturo Borrero Gonzalez, week 1

Arturo Borrero Gonzalez arturo.borrero.glez at gmail.com
Sat May 30 13:03:45 UTC 2015

# GSoC 2015 week 1 report

For this first week, I've selected these packages for me to begin with:

 * varnish-agent [0]
 * libuv [1]
 * samtools [2]

I think they are few packages, but I can't be fulltime with GSoC yet,
given I have some unexpected
University duties :-(

[0] https://buildd.debian.org/status/fetch.php?pkg=varnish-agent&arch=mipsel&ver=2.2~git20130708-1&stamp=1378414522
[1] https://buildd.debian.org/status/fetch.php?pkg=libuv&arch=mipsel&ver=0.10.36-1&stamp=1430177717
[2] https://buildd.debian.org/status/fetch.php?pkg=samtools&arch=mipsel&ver=1.1-1&stamp=1411612103

## varnish-agent

I was able to reproduce the build issue locally.
A related bug was already opened #724479 [3].

I generated a patch to address the issue, but a new error happened:

foreign/vsb.c:44:24: fatal error: varnishapi.h: No such file or directory
 #include <varnishapi.h>
 * sent the patch for #724479 [3] and tagged 'patch'.
 * openend bug #787253 [4] about missing varnishapi.h

[3] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=724479
[4] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=787253

## libuv

There seem to be a related bug already opened #774849 [5] and tagged

However, I tried to reproduce the issue locally and what I get is not
exactly the same as
reported by buildd. This will require further investigation.

[5] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=774849

## samtools

There seem to be a couple of related bugs already opened: #762647 [6]
and #753485 [7] (this last one tagged 'patch').

I tried to reproduce the build issues locally. Surprisingly, the
embedded test system
reports 87 failed tests on buildd but just 1 locally.
This will required further investigation.

[6] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=753485
[7] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=762647

## ci20

Imagination Technologies [8] gave me a ci20 [9] mipsel board (thank
you dudes!!).
I upgraded my ci20 board from Debian Wheezy to Debian Jessie.
Some errors happened which will require further investigation:

 * the new aptitude version segfaults
 * unable to install udev from jessie (complains about kernel config,
 * no switch to systemd happened (not sure why yet, perhaps missing udev)

I'm unable to use reportbug in the ci20 board, the following error arises:
 Attempt to unlock mutex that was not locked

This will require further investigation as well.

At the end, I downgraded the ci20 from Jessie to Wheezy.

[8] http://www.imgtec.com/
[9] http://elinux.org/MIPS_Creator_CI20

## workflow

My workflow is:

 * investigate the package (buildd logs, debian bug reports, upstream bugs..)
 * reproduce the issue locally
 * contact upstream regarding the issue if neccesary
 * try to generate a patch and open required debian bugs if neccesary

I'm using pbuilder inside the ci20 to emulate a clean Debian sid environment.

Some commands I'm using:
 % dget -x <dsc url> # donwload the source code of the package
 % sudo pbuilder create --distribution sid # create the pbuilder environment
 % sudo pbuilder build package.dsc # build a source package
 % quilt {new|refresh} mipsel.path # generate a new patch
 % dpkg-source -b pkgdir/ # generate again the source package for pbuilder

Arturo Borrero González

More information about the Soc-coordination mailing list