[Debian-handbook-translators] WARNING: Message missing from PO file, But couldn't update the PO file

AYANOKOUZI, Ryuunosuke i38w7i3 at yahoo.co.jp
Wed Mar 15 15:58:16 UTC 2017

Dear Giap,

At Tue, 14 Mar 2017 23:02:28 +0700,
Giap Tran <txgvnn at gmail.com> wrote:
> On 03/14/2017 22:23, AYANOKOUZI, Ryuunosuke wrote:
> > Please try to run command "publican update_pot" and run the command above again.
> > "publican update_pot" will update POT msgids with "en-US/*.xml" and
> After I run this command to update_pot, then I run `publican
> update_po..` in branch jessie/master
> It throw some errors
> pot/08_basic-configuration.pot:1503:703: invalid control sequence
> pot/08_basic-configuration.pot:1503:710: invalid control sequence
> I checked the line 1503:703 in pot/08_basic-configuration.pot as below:
> <literal>HKLM\SYSTEM\CurrentControlSet\Control
> Publican has reported the characters: \S \C \C

It is (might be) because
Old Perl Locale::PO module does not properly handle escape character [1].

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1143757

> I have tried publican 4.3.2-1 (jessie)  and 4.2.6-1 (stretch), But both
> of them get the same result.

Please check if you are using Locale::PO >= 0.25.

> What version of publican are you using?

publican from debian package (4.3.2-1)
and liblocale-po-perl (0.27-1) package under sid.

> Do you have any idea for my case?

Please check order of Perl library path also.

Sincerely yours,
Ryuunosuke Ayanokouzi
AYANOKOUZI, Ryuunosuke <i38w7i3 at yahoo.co.jp>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 473 bytes
Desc: OpenPGP Digital Signature
URL: <http://lists.alioth.debian.org/pipermail/debian-handbook-translators/attachments/20170316/93debe59/attachment.sig>

More information about the Debian-handbook-translators mailing list