[xml/sgml-pkgs] Bug#482140: Bug#482140: must be /etc/sgml

Daniel Leidert daniel.leidert at wgdd.de
Thu May 29 23:45:40 UTC 2008

Am Mittwoch, den 28.05.2008, 22:34 +0200 schrieb Xavi Drudis Ferran:

> I'm sending my /var/lib/dpkg/info/docbook-xml.postinst

Please set -ex at the top of the script to get more output and then just
configure the package (dpkg -a docbook-xml). This should show, which
command fails.

> The line that's failing is the one after the initial for loop:
> update-catalog  --add --super /etc/sgml/docbook-xml.cat
> In my /etc/sgml/catalog I already have a line with /etc/sgml/docbook-xml.cat
> and it's also in /etc/sgml/catalog.old

But update-catalog will not fail in this case. Try it yourself by
running the command as root again and again.

> I'm attaching a tarball of /etc/sgml (before playing with the scripts)
> But the .prerm script looks like it should have removed the docbook-xml.cat entry.
> In fact it does if I run it with "upgrade" as an argument
> In my /var/log/dpkg.log it looks like docbook-xml 4.4-5 was installed, and afterwards
> and upgrade to 4.5-5 was attempted but it was left half-configured
> So my only guess is that maybe the prerm script in docbook-xml 4.4-5 did not
> run update-catalog --quiet --remove --super /etc/sgml/docbook-xml.cat
> for some reason ?

The postinst script removes this file during the "configure" task.
Further it will not fail, even if the file still exists.

> Maybe the bug is in etch, not lenny, but it can be worked around in lenny ?

I really have no clue about the issue atm. For me everything works (I
now ran 3 upgrades in a CHROOT - all successful) and I currently have no
idea, which part could fail/fails.

Regards, Daniel

More information about the debian-xml-sgml-pkgs mailing list