[Freedombox-discuss] Test if your freedombox is working as it should (testsuite)

A. F. Cano afc at shibaya.lonestar.org
Sat Apr 5 04:00:06 UTC 2014

On Fri, Apr 04, 2014 at 07:16:49AM -0500, James Valleroy wrote:
> On Mon, Mar 24, 2014 at 12:49 PM, Sunil Mohan <sunil at medhas.org> wrote:
> > ...
> > It would be nice to have all this documented.
> I added a "Network Configuration" section to the VirtualBoxImages page
> on the wiki [0]. This setup will be similar to the Dreamplug's, with
> eth0 connected to the outside network and eth1 connected to an
> internal network (only accessible by the host in this case).


> Currently, the VBox configuration needs to be done before first-run.

Here's what I did, per the wiki instructions.  I didn't need to change
the setup of eth0, which had been set by default as NAT.  This might
be necessary later, but for now these changes and a newly-built fbx
image have gotten me a bit further.

Selected "Enable PAE/NX" (was previously not selected).  This probably
doesn't matter at this point since the makefile created a 486 image.

File -> Preferences -> Network -> Host-only Networks -> Edit
changed the IP to and disabled the DHCP server (for
interface 2)

The outward-facing interface (per the instructions) needs to be put in
"bridged adapter" but for now left it as it is (NAT). ping/nslookup
work fine, so the packets do get out to the internet.

Then tried the image built about 10 days ago.  It failed the same way
as before.  Tried to download the weekly image listed on the wiki page
by torrent, but it was "temporarily unavailable", so did another git
clone and make.

When I ran the virtualbox machine, it started the boot process, then
when it got to setting up eth0 it started shutting down again and
rebooted.  The second time, the boot process included detailed time
stamps.  It crashed with a "Kernel panic - not syncing: Fatal exception
in Interrupt".  A restart of the machine saw the sucessful completion
of the boot process and I got the login prompt.  Eth1 is now properly

Pointing the browser at results in a few warnings
about certificates, but at least I connected with the freedombox and
got the firstboot page.

When configuring the "WAN Connection", it didn't like the DHCP option.
Can't get out of that page.

My topology is as follows:         vboxnet0  192.168.3.x   eth0          DHCP
freedombox on virtualbox   ->   static IP network -> NAT router -> internet

Selecting "Statip IP" doesn't let me enter anything beyond 192 in the
first text field.  Clicking on any other text field (2, 3 or 4) goes
back to the first one.  Can't get out of that screen.  Tried this with
konqueror.  I'll keep investigating this tomorrow.  It's late.

> Then eth1 will be configured as and will provide DHCP
> service on the host-only network.

This part worked, so some progress...

> I just listed the basic steps, but feel free to add more information
> if it's helpful.
> [0] https://wiki.debian.org/FreedomBox/VirtualBoxImages

More information about the Freedombox-discuss mailing list