[Freedombox-discuss] Trouble Building Raspberry Pi Image

Chris Troutner chris.troutner at gmail.com
Thu May 15 17:31:31 UTC 2014

I tried to copy the files in the boot partition from Pere's 3/20/14 build
to the boot partition of his 5/1/14 build. No luck! :-(

I followed your instructions to edit the /etc/default/bootlogd file so that
a log would be created as /var/log/boot, but the file was never created. I
was able to verify that the edited bootlogd file still existed and was
edited, so that tells me that boot never got to the point where it could
create the boot log file.

One difference I noticed is that the green status LED on the Raspberry Pi
briefly flashes a couple times upon power up before going dead. That is
more than I was getting with the 5/1/14 image, which never showed any life
on the status LED.

-Chris Troutner

On Wed, May 14, 2014 at 7:21 AM, Chris Troutner <chris.troutner at gmail.com>wrote:

> Great sleuthing, Nick. I appreciate  you looking into this.
> I'm going to try the hack you recommended in order to get V0.2 loaded. I
> really want to play with that. I'll document it on my blog.
> Now that I've played around with the Raspberry Pi and actually tried to
> load FreedomBox onto it, I'm more convinced than ever that it's an
> important piece of target hardware. These things are very easy to get into
> other peoples hands.
> Cheers!
> Chris Troutner
> http://experimentsinfreedom.wordpress.com/
> On Tue, May 13, 2014 at 7:12 PM, Nick Daly <nick.m.daly at gmail.com> wrote:
>> Nick Daly <Nick.M.Daly at gmail.com> writes:
>> > The immediate cause of the issue has been discovered, but we don't yet
>> > know why it's broken.  Using "kpartx -a $IMAGE.img", you can easily
>> > mount each partition of the image file and verify that the first
>> > (primary boot) partition of the Raspberry Pi image is empty other than a
>> > zero-byte start.elf file.  Because the boot partition is empty, the
>> > image has no data with which to boot.
>> It works fine with a DreamPlug.  Looking through F-M's
>> bin/mk_freedombox_image, the only difference I can find is that the
>> Raspberry Pi is missing uboot.  I'm trying to build an image with that
>> now.
>> Nick
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20140515/81b9592b/attachment.html>

More information about the Freedombox-discuss mailing list