[Freedombox-discuss] Trouble Building Raspberry Pi Image

Sunil Mohan sunil at medhas.org
Thu May 15 20:16:54 UTC 2014

On Thursday 15 May 2014 11:01 PM, Chris Troutner wrote:
> I tried to copy the files in the boot partition from Pere's 3/20/14
> build to the boot partition of his 5/1/14 build. No luck! :-(
> I followed your instructions to edit the /etc/default/bootlogd file so
> that a log would be created as /var/log/boot, but the file was never
> created. I was able to verify that the edited bootlogd file still
> existed and was edited, so that tells me that boot never got to the
> point where it could create the boot log file.
> One difference I noticed is that the green status LED on the Raspberry
> Pi briefly flashes a couple times upon power up before going dead. That
> is more than I was getting with the 5/1/14 image, which never showed any
> life on the status LED.

I did a bit of digging too. Files in /boot are the result of rpi-update
script which is being called from freedombox-setup/setup.d/10_hardware.
Like this:

# Install binary blob and kernel needed to boot on the Raspberry Pi.
raspberry_setup_boot() {
    # Packages used by rpi-update to make Raspberry Pi bootable
    apt-get install -y git-core binutils ca-certificates wget kmod

    wget https://raw.github.com/Hexxeh/rpi-update/master/rpi-update \
        -O /usr/bin/rpi-update
    chmod a+x /usr/bin/rpi-update
    mkdir -p /lib/modules
    touch /boot/start.elf
    SKIP_BACKUP=1 rpi-update > /root/rpi-update.log

I checked the /root/rpi-update.log and understood that the 'curl'
package which was dependency. Then I realized that Petter fixed the
problem recently and that I was using an older version of
freedombox-setup. I updated to the latest and started a build again. But
that is my build problem.

The rpi-update script seems to doing quite a few things with kernel
modules in /lib/modules apart from /boot. I suppose this is why putting
valid files in /boot didn't work (and partly worked) for you.

Since your boot partition is also mostly empty, can we see your

Thank you,


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20140516/fe1c7d44/attachment.sig>

More information about the Freedombox-discuss mailing list