[Freedombox-discuss] Trouble booting .6 on Dreamplug

James Valleroy jvalleroy at mailbox.org
Fri Oct 23 19:26:13 UTC 2015

On 10/23/2015 01:44 PM, Jack Wilborn wrote:
> Hi, be away a while, so I downloaded both the 8-10 and 10-18 images
> for the Dreamplug and checked them with gpg.
> Used 'dd' to write them to the usd card inside the box, where I
> usually use it...  It seems to boot ok, until it runs btrfs, then
> appears, maybe a loop, but drops out with an error.  Seems to be
> saying it can not find /dev/sda2.
> I'm suspicious that maybe the environment settings have changed and
> hoped someone would send me a printenv list of a working dreamplug. 
> After that I'll have to look elsewhere as it appears to be running on
> other dreamplugs.  I've tried some of the changes in the boot line
> with system=@, so something, but no changes.

Here's my printenv (worked for 0.5 image at least):

bootargs=console=ttyS0,115200 root=/dev/sda2 rootdelay=10
bootcmd=${x_bootcmd_usb}; ${x_bootcmd_kernel}; ${x_bootcmd_initrd};
setenv bootargs ${x_bootargs} ${x_bootargs_root}; bootm 0x6400000 0x6900000;
x_bootargs_root=x_bootargs_root=root=/dev/sda2 rootdelay=10
x_bootcmd_initrd=fatload usb 2 0x6900000 uInitrd
x_bootcmd_kernel=fatload usb 2 0x6400000 uImage
x_bootcmd_usb=usb start

Note that this is for boot from USB memory. For the internal SD card,
change "usb 2" to "usb 0".

I haven't gotten the 0.6 image working on dreamplug yet. But if you try
it, please let us know which version of u-boot you are testing with.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20151023/696764ef/attachment.sig>

More information about the Freedombox-discuss mailing list