[Freedombox-discuss] root/sudoer user credentials for freedombox-unstable_2015-08-07_virtualbox-amd64-hdd.vdi?

Amey Abhyankar sco1984 at gmail.com
Wed Sep 9 15:54:49 UTC 2015

On 9 September 2015 at 20:17, Michael <info at fonfon.at> wrote:
> The (non-root but sudo) user credentials can be found on the VirtualBox
> installation page:
> https://wiki.debian.org/FreedomBox/Hardware/VirtualBox#Using

Got it thanks. Able to login.

> These credentials will be removed in future releases,

That means testers/evaluators using VDI will be in big trouble.  :-)
I was unable to find IP address of freedombox from virtualbox console.
After logging using those credentials I was able to lookup ip address.  :-)

I think home users will have following issues if those credentials are
removed & if http is the only way to get access:-

- Not having dedicated DHCP server means user can not confirm which IP
freedombox host has taken.
- Not having dedicated DNS server means user can not browse the server
URL using host name unless added entry in /etc/hosts on both machine.
- If I am on Ethernet network & assuming that ISP modem is issuing
private IP to each device, more difficult to guess IP issued to
freedombox after lease is expired. [Most times here in India, access
to ISP modem/router is restricted.]

Those are just some points came in my mind after going through IP
issues over wi-fi.  :-)

>so it would be
> interesting to know why you can not connect to your FreedomBox.

I think culprit was restrictive access over my corporate wi-fi network.
I had same IP issue for another VDI in corporate network.
I had to connect to some VPN network & then boot VDI to get IP from
remote DHCP server via VPN tunnel ;-)

I just tried from home wi-fi and it worked.
I put network on 'bridged only' mode & freedombox took IP from DHCP
server of my TP-Link wi-fi router.
I am able to login via https & ssh without any issues now.
> Michael



More information about the Freedombox-discuss mailing list