[Freedombox-discuss] root/sudoer user credentials for freedombox-unstable_2015-08-07_virtualbox-amd64-hdd.vdi?

Marc Jones mjones at softwarefreedom.org
Wed Sep 9 15:37:57 UTC 2015


You may want to check what "Network" you have your virtualbox machine
connected to. Typically when I set up a new virtual machine it defaults
to connecting to the NAT network. You may need to set up port forwarding
to get it to work if you want to use NAT and connect to the VM from your
host machine. I have never played with port forwarding in VirtualBox.

Alternatively you could also try modifing the virtual machine's network
settings to attach to either the Bridged Network or Host-Only. I
generally run on Host-Only so my host machine can access the vm and all
of my VM's can talk to each other. Setting it to bridged Network will
expose the virtual machines to other physical devices on your home network.


On 09/09/2015 10:47 AM, Michael wrote:
> On 2015-09-09 13:02, Amey Abhyankar wrote:
>> Hello Michael,
>> Thanks for quick reply.
>> On 9 September 2015 at 15:40, Michael <info at fonfon.at> wrote:
>>> Hello Amey,
>>> can you ping the freedombox from your host system?
>> Yes. Using 'Internet network' & IP freedombox got is
> This is the address of the virtual host-only network. The virtual
> machine gets another address, usually that's, depending
> on the network configuration. Can you access this address?
>>> Then it should also be accessible with your web browser, i.e. with
>>> 'https://freedombox'. What you then see is the web admin interface
>> Unfortunately not accessible [via IP address]. Tried from multiple browsers.
>> I don't have access to DNS server to add A host record.
>> Also tried with 'http'.
>> Following error is displayed in Google Chrome browser when I type
>> I am not able to SSH to the vm from base machine. Says 'connection refused' :-/
>> Promiscuous mode: Allow all vm's.
> The (non-root but sudo) user credentials can be found on the VirtualBox
> installation page:
> https://wiki.debian.org/FreedomBox/Hardware/VirtualBox#Using
> These credentials will be removed in future releases, so it would be
> interesting to know why you can not connect to your FreedomBox.
> Michael
> _______________________________________________
> Freedombox-discuss mailing list
> Freedombox-discuss at lists.alioth.debian.org
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/freedombox-discuss

Marc Jones
Software Freedom Law Center
1995 Broadway, 17th Floor
New York, NY 10023
Tel: 212-461-1919
Fax: 212-580-0898
Email: mjones at softwarefreedom.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0xAC9364C7.asc
Type: application/pgp-keys
Size: 6435 bytes
Desc: not available
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20150909/cc7416e5/attachment.key>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20150909/cc7416e5/attachment.sig>

More information about the Freedombox-discuss mailing list