[Freedombox-discuss] Cannot ssh into the box any more

znoteer at hailmail.net znoteer at hailmail.net
Thu Jun 2 23:19:36 UTC 2016

On Thu, Jun 2, 2016, at 05:59, Jens Thiele wrote:
> znoteer at hailmail.net writes:
> > Will one of these qemu-* files work in place of qemu-arm-static? Or, do
> > I need to install something else?
> afair the package to install is:
> qemu-user-static
> $ apt-file search qemu-arm-static
> qemu-user-static: /usr/bin/qemu-arm-static
> qemu-user-static: /usr/share/man/man1/qemu-arm-static.1.gz

Hi Jens,

Thanks.  That was it.  I had to remove the other qemu stuff to avoid

But, I'm still not there.  I "mount -o" bind'd <everything>, and was
able to chroot to the fbx filesystem.  However, I don't want to
uninstall libpam-abl since the issue has been fixed.  I just want to
upgrade libpam-abl.

When I run apt-get update I get

Err:1 http://httpredir.debian.org/debian sid InRelease
  Ne parvient pas à résoudre « httpredir.debian.org »

That's "can't resolve httpredir.debian.org".  I don't really know where
to go in debugging a network connection in a chroot environment.  I
tried to cat /etc/resolv.conf but I get an error about no file of this
type, even though I typed "resolv." and used tab completion to get the
complete name.  The same thing happens with the less command.

Maybe I should just apt-get uninstall libpam-abl as Sunil initially
suggested.   I can reinstall it when I put the SD card back in the
Sheevaplug.  Any suggestions on how to proceed from here?


  znoteer at hailmail.net

http://www.fastmail.com - IMAP accessible web-mail

More information about the Freedombox-discuss mailing list