[Freedombox-discuss] Cannot ssh into the box any more

Sunil Mohan Adapa sunil at medhas.org
Fri Jun 3 01:59:09 UTC 2016

On 06/03/2016 04:49 AM, znoteer at hailmail.net wrote:
> When I run apt-get update I get
> Err:1 http://httpredir.debian.org/debian sid InRelease
>   Ne parvient pas à résoudre « httpredir.debian.org »
> That's "can't resolve httpredir.debian.org".  I don't really know where
> to go in debugging a network connection in a chroot environment.  I
> tried to cat /etc/resolv.conf but I get an error about no file of this
> type, even though I typed "resolv." and used tab completion to get the
> complete name.  The same thing happens with the less command.
> Maybe I should just apt-get uninstall libpam-abl as Sunil initially
> suggested.   I can reinstall it when I put the SD card back in the
> Sheevaplug.  Any suggestions on how to proceed from here?

1. Upgrading the package should be possible by booting the device,
visiting Plinth and triggering system-wide upgrade in software upgrades.

2. The chroot should be able to connect to network just like the rest of
the machine.  But I suppose there is an issue with DNS resolution.  Add
a temporary first line in /etc/resolv.conf as 'nameserver
<your-dns-server>' or 'nameserver' (warning: that one belongs to

3. If networking is not working for some reason, download the latest
pamabl package[1], copy it to chroot and after to go into chroot, do
'dpkg -i <package_file>' to upgrade.


1) https://packages.debian.org/sid/armel/libpam-abl/download


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: OpenPGP digital signature
URL: <http://lists.alioth.debian.org/pipermail/freedombox-discuss/attachments/20160603/1ce99ef3/attachment.sig>

More information about the Freedombox-discuss mailing list