[Freedombox-discuss] Cannot ssh into the box any more

znoteer at hailmail.net znoteer at hailmail.net
Sat Jun 4 18:53:09 UTC 2016

On Thu, Jun 2, 2016, at 21:59, Sunil Mohan Adapa wrote:
> On 06/03/2016 04:49 AM, znoteer at hailmail.net wrote:
> [...]
> > When I run apt-get update I get
> > 
> > Err:1 http://httpredir.debian.org/debian sid InRelease
> >   Ne parvient pas à résoudre « httpredir.debian.org »
> > 
> > I tried to cat /etc/resolv.conf but I get an error about no file of this
> > type, even though I typed "resolv." and used tab completion to get the
> > complete name.  The same thing happens with the less command.
> > 

> 2. The chroot should be able to connect to network just like the rest of
> the machine.  But I suppose there is an issue with DNS resolution.  Add
> a temporary first line in /etc/resolv.conf as 'nameserver
> <your-dns-server>' or 'nameserver' (warning: that one belongs to
> Google).

Hi Sunil,

Thanks, as always, for your generous help with my naive problems.

Your comment that networking should work in a chroot env made me look
for closely at why I could tab complete the filename /etc/resolv.conf
but couldn't cat it (find not found).

/etc/resolv.conf was a soft link that pointed to an non-existant file. 
I created a resolv.conf file and was in business.  After a successful
apt-get update, some sub-process beneath "apt-get install libpam-abl"
segfaulted, but libpam-abl was nevertheless upgraded.

The SD card is now back in the sheevaplug.  I've booted and logged in no
problem.  I'm now busily apt-get dist-upgrade'ing!

  znoteer at hailmail.net

http://www.fastmail.com - Send your email first class

More information about the Freedombox-discuss mailing list